Results 1 to 5 of 5

Thread: Sigma Lens not working autofocus

  1. #1

    Default Sigma Lens not working autofocus

    Hi All

    I face the problem with my Sigma 70-300 APO DG Macro lens.
    After using 2 or 3 times my Lens is not working auto focus on my D80 Body. So I need to send back to the shop that I bought or I need to send it to Sigma Service Center. Please suggest me and guide me.


    Thanks

  2. #2

    Default Re: Sigma Lens not working autofocus

    If your lens is 7 days old or less, and the store you bought it at allows you to exchange, go back to the store.

    If it's longer, go straight to Sigma. Save time. Look up their listing.

    CHEERS!

  3. #3

    Default Re: Sigma Lens not working autofocus

    Call them up if shop cannot help.

    Sigma Marketing (Singapore) Pte Ltd.

    3791 Jalan Bukit Merah #07-19 & 20
    E-Centre@Redhill Singapore 159471

    Tel:65-62739622
    Fax:65-62746011

  4. #4

    Default Re: Sigma Lens not working autofocus

    just go to the sigma service center.
    mine also faced similar focusing problems.
    they'll fix it for free.
    =)
    but i've already sold e lens!
    HAHAHA!
    I rather shoot my friends than shoot already established models!

  5. #5

    Default Re: Sigma Lens not working autofocus

    Thanks all friend. Thanks for your reply and suggestion.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •