Results 1 to 14 of 14

Thread: Problem with picture

  1. #1
    Member driveanegg's Avatar
    Join Date
    Sep 2009
    Location
    Choa Chu Kang
    Posts
    615

    Default Problem with picture

    Dont know if this is the right place to post this, moderators please help move to another place if its incorrect

    I just noticed this thing after trying out some long exposure shots.
    There are blackish spots in my images, round in shape, fixed in places....

    Pic1 (around and above the left most lamp post just after the bridge)


    Pic2(mostly around the left lower side of picture where its brighter)


    What are these spots ??? Do I need to do anything to get rid of them ??
    Having said that, I havent made them reappear by shooting my usual subjects (flowers)

    Thanks in advance for the advice !!
    I probably collect lenses more than I take pictures
    http://www.flickr.com/photos/33270154@N03/

  2. #2

    Default Re: Problem with picture

    Your sensor needs cleaning, thats all.

  3. #3
    Member dingaroo's Avatar
    Join Date
    Dec 2009
    Location
    Singapore | East
    Posts
    1,950

    Default Re: Problem with picture

    Tried cleaning your sensor? It could be on the lens ... use a blower first. If still persists, wet clean, using lens/sensor cleaning kit. If that does not remove the spot, send to service centre.

    HTH.
    A picture a day keeps the blues away!

  4. #4
    Senior Member JC1808's Avatar
    Join Date
    Nov 2008
    Location
    West
    Posts
    2,847

    Default Re: Problem with picture

    Reading threads where ppl asking on photos with dirt marks on it, and request to go for sensor cleanning. Just want to know sensor dirty is due to without good care on the camera sensor or it is normal for camera used for some time and this problem will appear?

  5. #5
    Senior Member limwhow's Avatar
    Join Date
    Jun 2009
    Location
    Life revolves arOnd East Coast
    Posts
    7,049

    Default Re: Problem with picture

    I studied both these two shots, and found that the spots occur exactly at the same places in both photos.
    I can find no EXIF data on your photos to see if they are taken with the same focal length or not.
    Thus, assuming the 2 photos are taken with your lens at different focal length, then it is likely that it is your sensor that is dirty.

    But just one word, check your lens first. Because I have had prior experience where my lens was dirty with water mark from rain drops and it gave dots like these.

  6. #6

    Default Re: Problem with picture

    Dust specks on DSLR sensors are inevitable. Dusts will appear when you shoot at smaller apertures and mostly invisible when shot wide open. There are many ways to clean the dust on the sensor..

    1. Try to use your camera's built in cleaning function.
    2. Use a blower to gently blow off the dust
    3. Try the sensor brush method
    4. Use the wet method (Sensor wand + Eclipse) for tougher dust which are welded to the sensor (Like Pollen)

    http://www.cleaningdigitalcameras.com/

    If you're too worried of any of these methods, please send your camera to your Service Centre for cleaning or use the feature "Dust Off Ref Photo" or PS away.

  7. #7
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,394

    Default Re: Problem with picture

    Quote Originally Posted by JC1808 View Post
    Reading threads where ppl asking on photos with dirt marks on it, and request to go for sensor cleanning. Just want to know sensor dirty is due to without good care on the camera sensor or it is normal for camera used for some time and this problem will appear?
    Our environment is not dust-free (except a few special facilities) and most cameras are not sealed. Pretty normal that dust is also inside your camera. You can't prevent it. Clean when necessary, several methods have been described here.
    EOS

  8. #8
    Moderator daredevil123's Avatar
    Join Date
    Oct 2005
    Location
    lil red dot
    Posts
    21,627
    Blog Entries
    1

    Default Re: Problem with picture

    Dust on sensor. Give your sensor a good blow. But be careful that nothing touches the sensor.

    Check by setting your aperture to around F22. Then shoot at blank white wall. See if the spots are still there. Repeat 1st step until all gone. If some spot refuses to leave, bring your camera down to service center to do a sensor cleaning. Probably below $30 to do it.

  9. #9

    Default Re: Problem with picture

    Certainly look like dust bunnies.

    Use blower. If spots still exist then send camera back to service center for sensor cleaning.

  10. #10
    Member driveanegg's Avatar
    Join Date
    Sep 2009
    Location
    Choa Chu Kang
    Posts
    615

    Default Re: Problem with picture

    Thanks all for helping !!!

    Lucky the dust doesnt appear until f13, most pics except landscape are ok

    Will send for cleaning. Meanwhile try to learn about clone stamp in PS (new to PS)

    Maybe should keep a lens permanant on the cleaned camera ... so no new dust can appear.... then BBB new toy

    Will keep shooting
    I probably collect lenses more than I take pictures
    http://www.flickr.com/photos/33270154@N03/

  11. #11
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,394

    Default Re: Problem with picture

    Quote Originally Posted by driveanegg View Post
    Maybe should keep a lens permanant on the cleaned camera ... so no new dust can appear.... then BBB new toy
    Futile. Neither the camera nor the normal lenses are sealed. And if it's not the dust at home then the lints and dust in your camera bag will find the way.
    EOS

  12. #12
    Moderator daredevil123's Avatar
    Join Date
    Oct 2005
    Location
    lil red dot
    Posts
    21,627
    Blog Entries
    1

    Default Re: Problem with picture

    Quote Originally Posted by driveanegg View Post
    Thanks all for helping !!!

    Lucky the dust doesnt appear until f13, most pics except landscape are ok

    Will send for cleaning. Meanwhile try to learn about clone stamp in PS (new to PS)

    Maybe should keep a lens permanant on the cleaned camera ... so no new dust can appear.... then BBB new toy

    Will keep shooting
    Dust is part of the DSLR experience. Even if you do not remove a lens, when you zoom, dust will get in.

    That is why when people say they avoid changing lenses to prevent dust, I always laugh. Dust will get in irregardless, so might as well change lenses as much as you want.

  13. #13
    Member driveanegg's Avatar
    Join Date
    Sep 2009
    Location
    Choa Chu Kang
    Posts
    615

    Default Re: Problem with picture

    Thanks to everyone for the invaluable advice !!
    They show up only from f11 onwards .... think i will keep to f11 until I can get the sensor cleaned by CSC ..... maybe get a ND filter to lengthen exposure times if I really need ...

    Thanks again!
    I probably collect lenses more than I take pictures
    http://www.flickr.com/photos/33270154@N03/

  14. #14

    Default Re: Problem with picture

    Quote Originally Posted by driveanegg View Post
    Thanks to everyone for the invaluable advice !!
    They show up only from f11 onwards .... think i will keep to f11 until I can get the sensor cleaned by CSC ..... maybe get a ND filter to lengthen exposure times if I really need ...

    Thanks again!
    you can learn to diy.

    those spots might be sensor dust. on the rare occasion, they might be dust on your lens rear element, and front element. if substantial enough, they can cause that.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •