Results 1 to 7 of 7

Thread: What DPP version needed for shots taken by Canon 5D?

  1. #1

    Default What DPP version needed for shots taken by Canon 5D?

    Hi,

    I'm new. I just "inherited" a Canon 50D and installed the DPP 3.5 (that came along with the camera box). I was trying to view someone else's Raw images shot with a Canon 5D, but they appear as grey boxes. Am I supposed to install a higher version of DPP like the 3.7?

    Grateful if anyone can help.

    Tks.
    Last edited by sweetdarby28; 24th December 2009 at 05:38 PM.

  2. #2

    Default Re: What DPP version needed for shots taken by Canon 5D?

    It can be downloaded from Canon's website, but I think 3.5 should be able to handle 5D's raw files.

  3. #3
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,388

    Default Re: What DPP version needed for shots taken by Canon 5D?

    5D or 5D2? The 5D is not a new camera so any software coming with 50D should be able to read those files form 5D. Please note: don't de-install your existing DPP, download the latest version from Canon and install over the existing version. DPP updates require a previous installation (silly way of checking whether you have the original CD, hence you own a Canon camera). But there's a workaround also.
    EOS

  4. #4

    Default What DPP version needed for shots taken by Canon 5D?

    Hi,

    Thanks for the replies and suggestions. I did a "dummy" install where I clicked on install pretty much everything they suggested (instead of the custom install button) for the CD that came with my Canon 50D box.

    So the version I have on my pc now is DPP v 3.5. But I'm still unable to view Raw Images shot by my brother's 5D. So, should I go ahead and download that v 3.7 from the Canon website without uninstalling anything from the 50D CD that i've put in?

    Thanks so much.

  5. #5

    Default Re: What DPP version needed for shots taken by Canon 5D?

    Hi, sorry, I realized his camera is a Canon 5D Mark II. Does it make any difference (in terms of the software used to view raw images)?

    Thanks again.

  6. #6
    Member 9V-Orion Images's Avatar
    Join Date
    Apr 2009
    Location
    Autenticate ALGRN @ 7987.8270
    Posts
    1,760

    Default Re: What DPP version needed for shots taken by Canon 5D?

    Quote Originally Posted by sweetdarby28 View Post
    Hi, Thanks for the replies and suggestions. I did a "dummy" install where I clicked on install pretty much everything they suggested (instead of the custom install button) for the CD that came with my Canon 50D box.

    So the version I have on my pc now is DPP v 3.5. But I'm still unable to view Raw Images shot by my brother's 5D. So, should I go ahead and download that v 3.7 from the Canon website without uninstalling anything from the 50D CD that i've put in?

    Thanks so much.

    Download the Digital Photo Professional 3.7.2 Updater for Windows
    and install it.

    Quote Originally Posted by sweetdarby28 View Post
    Hi, sorry, I realized his camera is a Canon 5D Mark II. Does it make any difference (in terms of the software used to view raw images)?

    Thanks again.
    Not if you are referring to the 3.7.2 update.
    CS Aviation / Flickr
    Per aspera ad astra

  7. #7
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,388

    Default Re: What DPP version needed for shots taken by Canon 5D?

    Quote Originally Posted by sweetdarby28 View Post
    Hi, sorry, I realized his camera is a Canon 5D Mark II. Does it make any difference (in terms of the software used to view raw images)?
    It does. There are several years of development between both models. It seems every new Canon model comes with some new specifics in the RAW format so that an update of DPP is mandatory.
    EOS

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •