Results 1 to 6 of 6

Thread: EOS1000D pop-up flash not working!!!!!

  1. #1

    Default EOS1000D pop-up flash not working!!!!!

    Hi all! i do not know why but ever since i started using phottix batt grip n e Nssin Di622, e pop up flash does not work anymore(when e nissin flash is unmount). I do not know if it's coincidence or it's due to either one of e things. I have tried removing the batt grip but it still does not work. What should i do? Does anyone has the same problem as well???
    Regards,
    Elwin

  2. #2
    Deregistered shaoken's Avatar
    Join Date
    Feb 2008
    Location
    Clementi/West Coast
    Posts
    2,115

    Default Re: EOS1000D pop-up flash not working!!!!!

    Not working as in..?

    If it does not pop-up.. From what I remember, there should be a button for you to make the built-in flash pop-up.

    But if it does not fire flash, I'm not to sure.
    Sorry.

  3. #3

    Default Re: EOS1000D pop-up flash not working!!!!!

    HI..thanks...well...i mean it does not pop up upon pressing the button to activate the flash...I even did firmware upgrade and stuffs but it says external flash is attached or flash power is turned off..but how isit possible for us to turn off e power for pop up flash? so was baffled by it. Even restored all settings back to factory default but it does not work....think i shall call into Canon tmr bahz....thanks anw... =)

  4. #4
    Deregistered shaoken's Avatar
    Join Date
    Feb 2008
    Location
    Clementi/West Coast
    Posts
    2,115

    Default Re: EOS1000D pop-up flash not working!!!!!

    Better bring it to Canon for servicing.

  5. #5
    Senior Member denniskee's Avatar
    Join Date
    Oct 2003
    Location
    bukit batok
    Posts
    5,468

    Default Re: EOS1000D pop-up flash not working!!!!!

    It could be the either :

    1) Circuit board problem.
    2) Pop up button faulty.
    3) Hot shoe button faulty.

    Of the 3, I only know how to check for the 3rd fault.

    Look for a tinny winny button at the hot shoe, under the "spring" on both side (d60 is the last camera that has 2 buttons). When that is depressed, it "tells" the camera there is something mounted on the hot shoe, dont pop up the flash!!

    What you can do, at ur own risk :

    1) Remove the base plate on the hot shoe using a twizzer.
    2) Unscrew the 4 tinny screws.
    3) Clean the button abit to ensure free movement.
    4) Assemble back.

    see this link
    http://www.clubsnap.com/forums/showt...ot+shoe+button

    If this doesnt solve the problem, than the fault may be either (1) or (2), send it to CSC.
    Last edited by denniskee; 10th December 2009 at 10:53 AM.
    photography makes one sees things from all angles.

  6. #6
    Member
    Join Date
    Aug 2004
    Location
    Singapore
    Posts
    156

    Default Re: EOS1000D pop-up flash not working!!!!!

    If it is still under warranty, just bring it to the service center.
    Try not to be tempted to "operate" on your camera unless you know you can safely take it apart and put it back together without a trace that you have open it up before.
    You would not want to void the warranty due to a botched job.
    Last edited by bartman; 10th December 2009 at 11:39 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •