Results 1 to 4 of 4

Thread: Driver not found - 500D

  1. #1

    Default Driver not found - 500D


    I just purchased a canon 500D, but I can't connect it to my laptop. When connected to the USB cable, my laptop prompted me that the camera driver is not found. Anyone knows where I can download the driver? Tried Canon website, but there isn't any driver available. Also would like to check if the image filename represents the estimate of the shutter? Cos the first few shots I tried, the filename start from 4000 over...


  2. #2
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Pasir Ris

    Default Re: Driver not found - 500D

    Please have a look in the Equipment section, Canon for similar threads.
    The camera box contains a CD with all necessary additional software. Please check there.
    For the file name: No. This naming sequence can easily be changed. Please search here in the forum or via Google for 'shutter count 500D.

  3. #3

    Default Re: Driver not found - 500D

    you should have cd that came with camera, that *should* contain the relevant driver.

    other than that, you don't really need to connect your camera to transfer images.. there is something called.. cf card reader or sd card reader.

    as for whether it is an estimate, read these:

    Many have experienced this same thing, myself included, and it has been explained by some that when a previously used CF card is inserted into the camera, the filing system can get bumped up depending on how many images had been previously shot on that CF card.
    for finding exact number of actuations:

    You cannot find the true actuation count without sending the body to Canon, however AstroJargon's 40D shutter count does a very good job of getting close - you just don't get a count of any actuations made in LiveView.
    relevant link of astrojargon..

  4. #4

    Default Re: Driver not found - 500D

    apparently the astrojargon EOSinfo app doesnt work for 500D at the moment.. a little update on the website notifies this.. i was wondering why it wasnt working on my 500D after repeatedly reinstalling it etc..


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts