Results 1 to 9 of 9

Thread: Troubleshooting Dry Cabinet

  1. #1

    Default Troubleshooting Dry Cabinet

    I have a DigiCabi DB-026 which I bought in 2003. The humidity was at 73% when the display caught my eye. I looked inside and saw that the red LED was on but the green LED was off.

    I emptied out the cabinet and turned the dial all the way to the left. The green LED still did not come on.

    I have a power adapter which allows me to set the voltage which I then tried. I set the voltage to 5volts (as indicated as the output on the original dry cabinet adapter) but this unit provides only 350mA whereas the original adapter provides 2.4A. I plugged this in. This resulted in a brighter lit red LED. Using this adapter, I rotated the dial but the only thing is that with the dial at the left the red LED is brighter than when the dial was at the right. The green LED remained out throughout the dial setting range.

    Thinking that perhaps the green LED is dead and that the dehumidifying is actually going on, I carried out the following test. The reading on the display showed that humidity was now at 64%. I rotated the dial all the way to the left; if the dehumidifier was working, the humidity reading should decrease. In 4 hours, it went from 64% to 68% - wrong direction if the humidifier was working. I opened the cabinet and felt for the moisture that should be collecting in the dehumidifier unit to be drawn out to the back of the unit but there was no water and the fins attached to the TE unit didn't feel cold at all.

    I contacted DigiCab who said that a replacement for the power adapter is $20 while the dehumidifier unit together with the power adapter is $60. This is a reasonable cost but these replacement parts will not carry any warranty. So if the replacement proves to be faulty when I get home, I'll be out $60. Also I believe DigiCabi would sell me a "refurbished" circuit unit so I would like to try anything before coming out with $60.

    Has anyone had this experience before and managed to fix it. The circuit looks very simple and the components don't look like they would succumb to "wear and tear".

    I someone has checked the voltage of the supplied power adapter, please also let me know what you've found. Mine shows 4.3volts.

    I've considered getting another dry cabinet but I'd end up getting the same size so I think it's pretty wasteful if I just tossed out this unit without trying to get it going again.

    Any advice?

  2. #2

    Default Re: Troubleshooting Dry Cabinet

    Try turning the knob the other way and leave it overnight.

    I remember reading something about the knob, someone turned it the wrong way (clockwise could mean increase in the de-humidification or increase in RH - forgot which was right). Can't find that thread though, memory is failing me.

    Found another one. http://www.clubsnap.com/forums/showthread.php?t=334666
    Last edited by Timolol; 26th September 2009 at 10:13 PM.

  3. #3

    Default Re: Troubleshooting Dry Cabinet

    Get another digital hygrometer to double check the internal humidity. Most specialized pet product store will carry them.

  4. #4

    Default Re: Troubleshooting Dry Cabinet

    Hi Timolol, Thanks for the suggestion. I'll try that.

  5. #5

    Default Re: Troubleshooting Dry Cabinet

    Just turned the dial all the way to the right and the red LED turned off completely. And the humidity display shows 80%.

  6. #6
    Senior Member limwhow's Avatar
    Join Date
    Jun 2009
    Location
    Life revolves arOnd East Coast
    Posts
    7,049

    Default Re: Troubleshooting Dry Cabinet

    Quote Originally Posted by gumby View Post
    Just turned the dial all the way to the right and the red LED turned off completely. And the humidity display shows 80%.
    Goodness... your dry cabinet has gone bonkers.

  7. #7
    Senior Member Diavonex's Avatar
    Join Date
    Sep 2008
    Location
    Admiralty
    Posts
    3,641

    Default Re: Troubleshooting Dry Cabinet

    Put a Thirsty Hippo in the dry cabinet; if RH comes down your dehumidifier unit is probably defective.

    You should be able to see result within a few hours.

    Also make sure the rubber seal on the door is not leaky or harden.
    Last edited by Diavonex; 28th September 2009 at 12:59 AM.

  8. #8
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,422

    Default Re: Troubleshooting Dry Cabinet

    Quote Originally Posted by gumby View Post
    I have a power adapter which allows me to set the voltage which I then tried. I set the voltage to 5volts (as indicated as the output on the original dry cabinet adapter) but this unit provides only 350mA whereas the original adapter provides 2.4A. I plugged this in. This resulted in a brighter lit red LED. Using this adapter, I rotated the dial but the only thing is that with the dial at the left the red LED is brighter than when the dial was at the right. The green LED remained out throughout the dial setting range.

    Thinking that perhaps the green LED is dead and that the dehumidifying is actually going on, I carried out the following test. The reading on the display showed that humidity was now at 64%. I rotated the dial all the way to the left; if the dehumidifier was working, the humidity reading should decrease. In 4 hours, it went from 64% to 68% - wrong direction if the humidifier was working. I opened the cabinet and felt for the moisture that should be collecting in the dehumidifier unit to be drawn out to the back of the unit but there was no water and the fins attached to the TE unit didn't feel cold at all.
    LED doesn't die that easily and often, safe to assume that the LED works well.
    From your description it looks to me as if either your your power adapter or dehumidifier unit doesn't work any longer. As suggested by others: check the hygrometer using a second one or Thirsty Hippo. If that's fine then contact Digi to get replacement parts. You can dismount the dehumidifier unit from the cabinet and bring to Digi, together with power adapter. Try there what works (dehumidifier gets cold when working), bring back and assemble back. Takes only a screwdriver and some time.
    There have been a couple of reported issues in the last year, seems that there was a faulty batch of dehumidifiers. Got mine exchanged as well within warranty period. Service Center is a bit off (Tagore Lane) but it worked well bringing only the unit and warranty card. No point lugging the whole cabinet around.
    EOS

  9. #9

    Default Re: Troubleshooting Dry Cabinet

    I cranked the dial all the way to the right last night. The red LED went off and the green LED never came on. In the morning, the LED status was the same and the reading on the display was 73%.

    Has anyone taken a voltmeter to their power supply? What is the tested output voltage?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •