Results 1 to 4 of 4

Thread: K-7 firmware v1.01 earlier and later version!

  1. #1

    Exclamation K-7 firmware v1.01 earlier and later version!

    Some guy at DPR reported that the firmware v1.01 has two versions:

    http://forums.dpreview.com/forums/re...ssage=32886371

    Obviously Pentax released two version of v1.01 firmware, and the later one fixed this thin green line problem some users encountered.

    Well, I just checked my K7 w/ ExifTools, the firmware version was:

    DSP Firmware Version: 1.01.00.05
    CPU Firmware Version: 1.01.00.05

    I haven't seen any green line or whatsoever on my camera, but since there is a new version out there, why not just upgrade. So I upgraded just now, now ExifTools shows mine as:

    DSP Firmware Version: 1.01.00.09
    CPU Firmware Version: 1.01.00.09

    The new firmware is the same date/size as the early one we downloaded on the first day (July 29th 2009) when it's released, but actually Pentax modified something to fix some problem, but they didn't tell us about it. They just put the new one there.

    So if you downloaded and installed the firmware on the first day or soon after it's released, you'd probably like to download and update again

    You can download the firmware here:

    Windows - http://www.pentaximaging.com/images/...0_k7_e101w.zip
    Mac - http://www.pentaximaging.com/images/...00_k7e101m.zip

    Make sure there is enough power in your battery when you update the firmware. Good luck.

  2. #2

    Default Re: K-7 firmware v1.01 earlier and later version!

    Some users at Pentaxforums also reported this newer firmware fixed the thin green line issue:

    http://www.pentaxforums.com/forums/p...tion-body.html

  3. #3
    Senior Member
    Join Date
    Dec 2005
    Location
    "River end"
    Posts
    4,249

    Default Re: K-7 firmware v1.01 earlier and later version!

    ok, updated too.

  4. #4

    Default Re: K-7 firmware v1.01 earlier and later version!

    Thanks for the info, FW. Just updated too!
    Strange that they avoided calling it Ver 1.02 instead.

    btw..after the update, did you notice a squeaking sound as you power on ? Was not there in the earlier version.
    Last edited by airconvent; 3rd September 2009 at 10:47 PM.
    PENTAXKR,18250,18135,35,40,70,600,AF360
    SONYA6000,1650,1855,18200,5018,3028,16,RX100M3

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •