Results 1 to 7 of 7

Thread: Sigma 17-70

  1. #1
    Member
    Join Date
    Jul 2009
    Location
    Minneapolis - St Paul
    Posts
    23

    Default Sigma 17-70

    I just recently bought a Sigma 17-70 but it's not the cleanest thing, I bought it for 315 shipped. I'm a total noob with this and this is the very first lens I bought after my kit lens that came with my camera.

    Here are some pictures.

    Do you guys know if lenspens will get rid of this mark? Can you even use lenspens to clean the back side of the lens? Or only the front? Because I never seen people use it to clean the back of the lens that goes inside the camera body.


    Also there is a small dot inside the lens, will this affect anything? (I don't think you can see it in this picture, it's small white dot-like thing). I hope it's not fungus, I don't even know what the early stages of fungus look like.

  2. #2
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,388

    Default Re: Sigma 17-70

    Never seen any remarks about "lenspen, never use for back element" - but I'd prefer a blower and a microfiber cloth.

  3. #3

    Default Re: Sigma 17-70

    doubt it is fungus, it looks like it is above, but i could be wrong.

    looks more like the lens coating has degraded.. for the rear element at least
    Last edited by night86mare; 4th August 2009 at 02:14 PM.

  4. #4
    Member
    Join Date
    Jul 2009
    Location
    Minneapolis - St Paul
    Posts
    23

    Default Re: Sigma 17-70

    Quote Originally Posted by night86mare View Post
    doubt it is fungus, it looks like it is above, but i could be wrong.

    looks more like the lens coating has degraded.. for the rear element at least
    Yeah thanks you guys, I can't see the dust anymore and no it's not fungus. Everything works fine. The lens came really dirty with dirt everywhere with teeny mud chunks sticking against the rubber grip. I cleaned it all up and now it's looking almost new except for the rear element. The rear element doesn't affect the image quality but it bugs me just looking at it like that. Is there anything I can do to neaten it out?
    Last edited by LeDave; 4th August 2009 at 02:33 PM.

  5. #5

    Default Re: Sigma 17-70

    if it isn't affecting your image quality, then don't bother about it, just leave it.

    the more you try to fiddle around with something that doesn't really require correction, the higher chances you have of doing something that requires correction

    "not itchy, don't scratch"

  6. #6
    Member
    Join Date
    Jul 2009
    Location
    Minneapolis - St Paul
    Posts
    23

    Default Re: Sigma 17-70

    Quote Originally Posted by night86mare View Post
    if it isn't affecting your image quality, then don't bother about it, just leave it.

    the more you try to fiddle around with something that doesn't really require correction, the higher chances you have of doing something that requires correction

    "not itchy, don't scratch"
    Hehe, you were right about that one. But I used microfiber cloth and gently swooped it around in a circular motion without applying pressure. It magically disappeared, I am very happy now. My lens is as good as new. Thanks you guys.

  7. #7

    Default Re: Sigma 17-70

    My sigma lens have coating peel too. One even has a shiny speck inside the front element but all these do not affect or show up in any image.

    But suprisingly, what appears to be perfect lens is the one with a visible dust in the picture.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •