Results 1 to 7 of 7

Thread: Problem with CF card

  1. #1

    Default Problem with CF card

    Hi,

    I have encountered several problems with my CF cards before, but they've always been solved by formatting the card (either in the camera or the computer).

    However, this time, I inserted my card into my D70s and it showed 'FOR'. I tried to format the card with the camera once, but the sign still remained. So I put it into my card reader. On the computer, it displayed 'the card has not been formatted', and subsequently prompted me to do so. The computer formatted the card, but when I put the card back into the camera, it still displayed 'FOR'.

    I tried to format the card on the camera again, but this time the green light kept on for a very long time (around 3 minutes). However, it still showed 'FOR'. I've tried to take out the card and put it back in again, and sometimes it shows 'CHA', but usually 'FOR'.

    What should I do? It's a Sandisk Ultra II 4GB and usually has no problems on my D70s.

    Thanks.

  2. #2

  3. #3
    Moderator chngpe01's Avatar
    Join Date
    Oct 2002
    Location
    Singapore, Singapore, Singapor
    Posts
    9,859
    Blog Entries
    7

    Default Re: Problem with CF card

    Try on another card. If the problem persist on all other cards, then it is likely to be the camera and not the cards.

  4. #4

    Default Re: Problem with CF card

    camera work well with my other cards - only this card doesnt work.

    tried cleaning the contacts, but it doesnt seem to help

    thanks
    Last edited by 2.8photography; 1st August 2009 at 10:40 AM.

  5. #5
    Senior Member CS TAN's Avatar
    Join Date
    Sep 2007
    Location
    Hong Kong
    Posts
    3,663

    Default Re: Problem with CF card

    Then either go back to the vendor for 1-1 exchange if it carries "limited life time warranty" or buy a new one since this one apparently is dead. And, you really don't want to risk the images getting corrupted on any of your important events.
    Canon 5D Mark II | 24-105L | 35L | 85L II | 135L | Samyang 14mm 2.8

  6. #6
    Senior Member Lomographer's Avatar
    Join Date
    Apr 2009
    Location
    Paterson Road
    Posts
    2,047

    Default Re: Problem with CF card

    I agree.

    Try testing the card out on the com

    And then insert another card into the camera

    If it still persist, of maybe your camera that's causing the problem
    Pentax K-x

  7. #7

    Default Re: Problem with CF card

    Quote Originally Posted by CS TAN View Post
    Then either go back to the vendor for 1-1 exchange if it carries "limited life time warranty" or buy a new one since this one apparently is dead. And, you really don't want to risk the images getting corrupted on any of your important events.
    i have the bad habit of throwing away receipts and warranties for things i buy (except lenses/cameras/flashes) so i suppose i wont be able to get an exchange right?

    is there any way of 'saving' the card?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •