Results 1 to 8 of 8

Thread: Battery problem with 5Dmk1 with grip

  1. #1

    Default Battery problem with 5Dmk1 with grip

    Good Day,

    I would like to ask all the 5Dmk1 with Grip user.

    Do you faced battery indicator problem with your set?
    The battery indicator will show only 1 bar despite full charged for both batteries in your grip?

    ANyone has this problem with 3rd party battery?

    I tried mine.

    Put in 1 original - battery show 1 bar.
    Put in 1 3rd party - battery indicator show one bar and blink after a while.
    Put in 1 orginal + 1 3rd party - Full bar a short while but changes to 1 bar. Can shoot whole day but occasionally just died on me... just open close the cover, change battery around and will be fine.

    Anyone has this problem?
    How to solve this? I also tried to clean the battery connector points..but problem still exists.
    Please advise.
    Thank you.

  2. #2
    Senior Member Galdor's Avatar
    Join Date
    Jul 2006
    Location
    Planet Gaia
    Posts
    9,544

    Default Re: Battery problem with 5Dmk1 with grip

    How old are the batteries? Do the batteries behave the same if inserted into the cam body directly?
    Minolta. Konica Minolta. Sony

  3. #3
    Senior Member
    Join Date
    Jan 2005
    Location
    Pasir Ris, Singapore
    Posts
    14,002

    Default Re: Battery problem with 5Dmk1 with grip

    Initially i had this same problem with my 5D after getting it the first day new. After some time no more such problems.
    Canon EOS 5D, 24-70 f/4 L IS, 50 f/1.2 L, 70-300 f/4-5.6 L IS, 600EX-RT. Sigma 12-24 f/4.5-5.6 EX.

  4. #4

    Default Re: Battery problem with 5Dmk1 with grip

    Galdor : If i remove the grip, and put in just the single battery...it shows full bar...for both 3rd party and orginal battery. Therefore my guess is something to do with the grip. I also faced the same problem with my previous 350D.

    Snoweagle: How do you solved it? Can enlightened me?

  5. #5
    Senior Member
    Join Date
    Jan 2005
    Location
    Pasir Ris, Singapore
    Posts
    14,002

    Default Re: Battery problem with 5Dmk1 with grip

    Quote Originally Posted by Planner View Post
    Galdor : If i remove the grip, and put in just the single battery...it shows full bar...for both 3rd party and orginal battery. Therefore my guess is something to do with the grip. I also faced the same problem with my previous 350D.

    Snoweagle: How do you solved it? Can enlightened me?
    I didn't solve it. After a while it just went away.
    Canon EOS 5D, 24-70 f/4 L IS, 50 f/1.2 L, 70-300 f/4-5.6 L IS, 600EX-RT. Sigma 12-24 f/4.5-5.6 EX.

  6. #6
    Senior Member Galdor's Avatar
    Join Date
    Jul 2006
    Location
    Planet Gaia
    Posts
    9,544

    Default Re: Battery problem with 5Dmk1 with grip

    Quote Originally Posted by Planner View Post
    Galdor : If i remove the grip, and put in just the single battery...it shows full bar...for both 3rd party and orginal battery. Therefore my guess is something to do with the grip. I also faced the same problem with my previous 350D.

    Snoweagle: How do you solved it? Can enlightened me?
    It could be the contacts in the battery grip. Try cleaning them to see if it helps.
    Minolta. Konica Minolta. Sony

  7. #7
    Senior Member ricleo's Avatar
    Join Date
    Mar 2004
    Location
    Eastern Singapore
    Posts
    6,551

    Default Re: Battery problem with 5Dmk1 with grip

    i think there was a known contacts problem with the 5D, i used to face that as well, but it goes away and comes back once in a while, not a big problem for me as i always keep only 1 battery in the grip and replace it if it goes empty.
    A7R3|V12|V15|FE28|MS17|MS35|MS50|50lux|50C|50Artis an|FD85L|FE85|90 cron|
    Σ24|35L|Σ50|135L|70-200G2

  8. #8

    Default Re: Battery problem with 5Dmk1 with grip

    Galdor : Yup i tried cleaning the grip contact points and the batteries contact point. But still.....haiz..

    Ricleo : Oh, this is a known problem? ok i just hope mine go away as well.... Actually mine just had this problem recently ... and it became worst when the whole camera went dead on me while i was shooting. I have to remove the grip, swop the batteries...to let it live again... .but then it went dead again after some time.. argghh....

    Just hope this is a temporary problem and hope i am this problem will go away soon....

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •