Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Thread: Whats that on my lens??!?!

  1. #1

    Default Whats that on my lens??!?!

    Can someone help me check what's that on my lens? (black spots at the top left and right) Never realized it was there, doesn't show on any of my other pics except this, my guess is because I stopped down to F22.

    Is it dust or is it fungus or...? UFO?

    Not sure if its very clear in the low-res.

    If you wanna C&C the picture, go ahead too, I could use some tips. Lens is a 20mm F1.8 Sigma

    Looking for Canon 100mm F2 USM :)

  2. #2

    Default Re: Whats that on my lens??!?!

    You have answered your own question.
    Time to clean your lens.

    It's dust on your lens, btw.

  3. #3

    Default Re: Whats that on my lens??!?!

    Bro there dust on your sensor, u may need to clean it
    http://www.golfer71.multiply.com
    limken 화랑에 사진

  4. #4

    Default Re: Whats that on my lens??!?!

    Dust on lens is usually not an issue. My bet is that its on the sensor. You might wanna change lens and see if you get the same spots.
    D3s / D3x / 18-55 f3.5 - 5.6 / 55-200 f3.5-5.6 / 50 f1.8

  5. #5
    Member/Tangshooter Redsun's Avatar
    Join Date
    Nov 2005
    Location
    Singapore
    Posts
    7,932

    Default Re: Whats that on my lens??!?!

    i'll bet its sensor dust

  6. #6
    Senior Member
    Join Date
    Apr 2008
    Location
    Singapore, east-ish
    Posts
    2,291

    Default Re: Whats that on my lens??!?!

    yep, pretty sure it's just dust, not fungus or whatnot

    Try lightly blowing a few jets of air down the sensor to dislodge it. If that doesn't work, send for cleaning


    oh and C&C?too much 'boring grey-blue' sky You could have put the sun higher up in the frame?
    Last edited by Daedalus Trent; 4th November 2008 at 09:03 AM.

  7. #7
    Senior Member
    Join Date
    Jul 2006
    Location
    Clementi
    Posts
    10,596

    Default Re: Whats that on my lens??!?!

    Quote Originally Posted by S L Chai View Post
    You have answered your own question.
    Time to clean your lens.

    It's dust on your lens, btw.
    It's dust on the sensor. That is most likely. Dust on the lens will only appear if it is very near or on the rear element.

  8. #8

    Default Re: Whats that on my lens??!?!

    Shouldn't be on the sensor I think, all my shots were fine only until F16 onwards, I'm guessing the DOF encompassed the stuff in the lens too. (Okay bad concept actually) The lens does have abit of dust inside, but I didn't think it was a big issue when I bought it. How am I going to clean dust inside the lens? T.T
    Looking for Canon 100mm F2 USM :)

  9. #9
    Senior Member
    Join Date
    Apr 2008
    Location
    Singapore, east-ish
    Posts
    2,291

    Default Re: Whats that on my lens??!?!

    Quote Originally Posted by ombre View Post
    Shouldn't be on the sensor I think, all my shots were fine only until F16 onwards, I'm guessing the DOF encompassed the stuff in the lens too. (Okay bad concept actually) The lens does have abit of dust inside, but I didn't think it was a big issue when I bought it. How am I going to clean dust inside the lens? T.T
    nope, i'm pretty sure it's on the sensor

    like you said, the spots only show @ f16 onwards.

  10. #10

    Default Re: Whats that on my lens??!?!

    Quote Originally Posted by Daedalus Trent View Post
    yep, pretty sure it's just dust, not fungus or whatnot

    Try lightly blowing a few jets of air down the sensor to dislodge it. If that doesn't work, send for cleaning


    oh and C&C?too much 'boring grey-blue' sky You could have put the sun higher up in the frame?
    The sun is actually on the 1/3 line of the lower frame... below it are buildings. I cropped it away coz they were underexposed and I was far too lazy to do a stitch up (which I had in mind when I shot it).

    Focus on the sun isn't very nice too I think... I guess landscaping isn't my cup of tea.
    Looking for Canon 100mm F2 USM :)

  11. #11
    Member alexyap1205's Avatar
    Join Date
    May 2008
    Location
    Singapore
    Posts
    170

    Smile Re: Whats that on my lens??!?!

    I have the same thing before. It's dust on your sensor.

    Time to clean your sensor.
    M Y S I G N A T U R E :)

  12. #12

    Default Re: Whats that on my lens??!?!

    As wat all other CS'ers mentioned, it's pretty much concluded that the sensor is dirty.
    U can PM fatigue, our fellow CS'er for his service to clean ur cam.

  13. #13

    Default Re: Whats that on my lens??!?!

    Right.. its dust on sensor. Darn it. I tested it with another clean lens.

    UGH!
    Looking for Canon 100mm F2 USM :)

  14. #14

    Default Re: Whats that on my lens??!?!

    Quote Originally Posted by rexlim View Post
    As wat all other CS'ers mentioned, it's pretty much concluded that the sensor is dirty.
    U can PM fatigue, our fellow CS'er for his service to clean ur cam.
    How much fatigue charge anyway? Anyone knows?
    Looking for Canon 100mm F2 USM :)

  15. #15
    Senior Member
    Join Date
    Apr 2008
    Location
    Singapore, east-ish
    Posts
    2,291

    Default Re: Whats that on my lens??!?!

    Quote Originally Posted by ombre View Post
    How much fatigue charge anyway? Anyone knows?
    Well, before you send it, try blowing the sensor gently with your blower (without touching it!) It's free and if the dust isn't lodged firmly, your problem can be easily solved

  16. #16

    Default Re: Whats that on my lens??!?!

    Haha ok thanks. Anyway I realize you own a 70-200mm, isn't that a heavy bat?

    Waiting for my battery to charge now so that I can clean my sensor... =(
    Looking for Canon 100mm F2 USM :)

  17. #17
    Senior Member
    Join Date
    Apr 2008
    Location
    Singapore, east-ish
    Posts
    2,291

    Default Re: Whats that on my lens??!?!

    Quote Originally Posted by ombre View Post
    Haha ok thanks. Anyway I realize you own a 70-200mm, isn't that a heavy bat?

    Waiting for my battery to charge now so that I can clean my sensor... =(
    Heavy bat?

  18. #18

    Default Re: Whats that on my lens??!?!

    Yup, dust on sensor, very common and normally only see with small aperture...

    Just do a mirror lock up and blow away the dust with blower...

  19. #19

    Default Re: Whats that on my lens??!?!

    70-200 F2.8 goes beyond 1kg doesn't it? How much did you get it for? OT a little. =X


    Anyway I just cleaned my sensor. Did it twice because of some stupid incident.

    After the first cleaning, the situation improved, but I did a test shot and was like WOAH, one big huge hair line across the screen. I thought some fibre got in, I opened it to clean it up again.

    Opened it up, the sensor looks minty... no sign of anything, well, just to be safe, I blew everything up again.

    Only to realize... the hair was actually a hair on the floor that my Marco lens picked on. I didn't notice it on the VF lol.


    Thanks for the help guys!
    Looking for Canon 100mm F2 USM :)

  20. #20

    Default Re: Whats that on my lens??!?!

    Quote Originally Posted by Daedalus Trent View Post
    yep, pretty sure it's just dust, not fungus or whatnot

    Try lightly blowing a few jets of air down the sensor to dislodge it. If that doesn't work, send for cleaning


    oh and C&C?too much 'boring grey-blue' sky You could have put the sun higher up in the frame?
    he juz want to test his dust spot mah...

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •