Results 1 to 12 of 12

Thread: Possible Problem with lens: Advice needed

  1. #1

    Default Possible Problem with lens: Advice needed

    I bought my DSLR about a month ago. When I take pics, some pics, especially those that I did not zoom into have a black mark at a specific location. I checked all my lens and I think I found the problem.

    Its a dust particle stuck in the lens. I'm just wondering if its possible to open the lens and wipe the inside of it.

  2. #2
    Member
    Join Date
    Oct 2007
    Location
    Western Singapore
    Posts
    91

    Default Re: Possible Problem with lens: Advice needed

    Perhaps you can show us a photo with the mark? just curious did the lens come with the dslr or bought separately. if new lens most probably its dust on your sensor and not the lens.

  3. #3

    Default Re: Possible Problem with lens: Advice needed

    Quote Originally Posted by Magede View Post
    I bought my DSLR about a month ago. When I take pics, some pics, especially those that I did not zoom into have a black mark at a specific location. I checked all my lens and I think I found the problem.

    Its a dust particle stuck in the lens. I'm just wondering if its possible to open the lens and wipe the inside of it.
    caaaaaan, if you want to void your warranty. just drop by the service centre and have them clean it. it'll take less than 20 mins.
    It is such a quiet thing to fall,
    But far more terrible is to admit it

  4. #4

    Default Re: Possible Problem with lens: Advice needed

    http://www.flickr.com/photos/28757463@N05/2798649230/
    http://www.flickr.com/photos/28757463@N05/2797819371/
    http://www.flickr.com/photos/28757463@N05/2817034024/

    the mark is near the top right corner of the pic. Alwaysd appears at the same spot and it isn't there when I zoom into things.

    The lens came with the camera. Bought it at Tangs when they had the Sigma promotion there.
    Last edited by Magede; 3rd September 2008 at 10:19 PM.

  5. #5

    Default Re: Possible Problem with lens: Advice needed

    i'm certain it's dust on the sensor.
    just drop by the service centre and have them clean.

  6. #6

    Default Re: Possible Problem with lens: Advice needed

    if there is warranty send to the service centre.

  7. #7

    Default Re: Possible Problem with lens: Advice needed

    problem is, I'm overseas and will be out of the country for another 38 days. Any way i can do it myself?

  8. #8

    Default Re: Possible Problem with lens: Advice needed

    Do you have more than one lens? The dirt may be on the sensor.
    Meow!

  9. #9

    Default Re: Possible Problem with lens: Advice needed

    try another lens, see if the spot is still there. if it is then its on your sensor, and i don't advise cleaning your sensor 'cause its really fragile/sensitive.
    It is such a quiet thing to fall,
    But far more terrible is to admit it

  10. #10

    Default Re: Possible Problem with lens: Advice needed

    Quote Originally Posted by Magede View Post
    problem is, I'm overseas and will be out of the country for another 38 days. Any way i can do it myself?
    Which model?

  11. #11

    Default Re: Possible Problem with lens: Advice needed

    Quote Originally Posted by lsisaxon View Post
    Which model?
    Sigma SD14 according to the EXIF.

    Threadstarter, you can clean the sensor on your own if you have a blower. Otherwise, you may want to check for a Sigma service center wherever you are.
    Alpha

  12. #12

    Default Re: Possible Problem with lens: Advice needed

    ok thx alot for the advice.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •