Results 1 to 14 of 14

Thread: Some unknow particle on my photos

  1. #1

    Default Some unknow particle on my photos



    what is that ah? dust at mirror lens or sensor?

    appear to be at aperture f/5.0

    can i clean it myself or do i have to send to CSC? still on 1 year canon warranty

  2. #2
    Deregistered
    Join Date
    Jul 2008
    Location
    Selegie
    Posts
    305

    Default Re: Some unknow particle on my photos

    Definitely not on mirror. When the picture is taken, the mirror flips out of the way. Likely to be on sensor.

  3. #3
    Member lennyl's Avatar
    Join Date
    Mar 2008
    Location
    Northern California
    Posts
    1,520

    Default Re: Some unknow particle on my photos

    Quote Originally Posted by gaoxing840 View Post


    what is that ah? dust at mirror lens or sensor?

    appear to be at aperture f/5.0

    can i clean it myself or do i have to send to CSC? still on 1 year canon warranty
    This image was shot at f/22.

    Likely dust or very short hair. Check the lens (both ends) as well as the sensor. Use an air blower, see if you can blow it off. Do NOT use canned air. Use a bulb type like Giotto's Rocket Blower. Edit : check rear element of lens, not both ends (but you might as well take the opportunity to clean the front element). See calebk's post below.

    Canon warranty does not cover cleaning. They'll charge you $20 + GST or something around there.

    Edit : dust may not be visible to the eye (although yours looks big, so should be visible).
    Last edited by lennyl; 22nd August 2008 at 12:19 PM.

  4. #4
    Senior Member
    Join Date
    Jul 2006
    Location
    Clementi
    Posts
    10,596

    Default Re: Some unknow particle on my photos

    Lenny, if dust appears on your image, check the sensor, then the rear element. These are the two most likely causes. Dust on the front element usually never appears in images (unless you have dust bunnies - then it'll appear in the form of flare).

  5. #5
    Member lennyl's Avatar
    Join Date
    Mar 2008
    Location
    Northern California
    Posts
    1,520

    Default Re: Some unknow particle on my photos

    Quote Originally Posted by calebk View Post
    Lenny, if dust appears on your image, check the sensor, then the rear element. These are the two most likely causes. Dust on the front element usually never appears in images (unless you have dust bunnies - then it'll appear in the form of flare).
    Yeah, you're right. I realized that after I hit "post", but was too lazy to go back to edit. My bad.

  6. #6

    Default Re: Some unknow particle on my photos

    i use the blower to blower the rear lens and the sensor. but its still there??

    canon still charge for cleaning?

  7. #7
    Deregistered
    Join Date
    Jul 2008
    Location
    Selegie
    Posts
    305

    Default Re: Some unknow particle on my photos

    Quote Originally Posted by gaoxing840 View Post
    .....canon still charge for cleaning?
    Who doesn't

  8. #8

    Default Re: Some unknow particle on my photos

    its very likely a dust. and yes canon charge $20 + cleaning ... and make sure you check after they clean, i had to ask them to re-clean for more than 3 times on the spot cos the dust still not properly clear

  9. #9

    Default Re: Some unknow particle on my photos

    i use my blower to blow off the sensor and the rear glass of the lens. its still there. argh!

    i saw it on the sensor using a torchlight. but i can't seem to blow it off.

    damn i think i need to send to CSC already
    Last edited by gaoxing840; 22nd August 2008 at 06:13 PM.

  10. #10

    Default Re: Some unknow particle on my photos

    will it be a scratch?

  11. #11

    Default Re: Some unknow particle on my photos

    Quote Originally Posted by mactigasuku View Post
    Who doesn't
    Sony almost never charges unless you send it in ever 2 weeks.
    Alpha

  12. #12

    Default Re: Some unknow particle on my photos

    i try blowing it off. its like the particle is stuck on the sensor.. i shone my torch in it. will it spoil the sensor?

  13. #13
    Member lennyl's Avatar
    Join Date
    Mar 2008
    Location
    Northern California
    Posts
    1,520

    Default Re: Some unknow particle on my photos

    Quote Originally Posted by gaoxing840 View Post
    i try blowing it off. its like the particle is stuck on the sensor.. i shone my torch in it. will it spoil the sensor?
    Shining light on sensor will not damage it (well, not unless you're using a laser or such anyway).

    There are several alternatives available to you, if you don't want to send it to Canon for cleaning. It could be that your blower is not strong enough, or you might need more aggressive method. You could try Petteri's brush method (google for it) or the Copperhill wet method (using Eclipse and Pec Pads, also google for it). Getting the material for the Copperhill method will likely cost more than $20, but it will last for many, many cleanings.

    As Canon likes to point out, any contact with the sensor risks damaging it.

    Before spending any more money, try this : I put my camera on my tripod, then hold the nozzle of the blower so that when I squeeze the bulb, I can direct the air. May help. Nothing to lose (except a few minutes of time).

    You know about using small apertures (f/22 or smaller) and shooting a blank wall or clear sky to check for dust on the sensor, right? If the image is totally out of focus, even better - only the dust will be in focus.

  14. #14

    Default Re: Some unknow particle on my photos

    i tried to use the blower with metal tip. blow lots of time with the camera facing down. its refuses to move sia.

    i think i have to bring down to canon there. don really know to clean it myself. haha

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •