Results 1 to 10 of 10

Thread: Fungus in Digi Cab

  1. #1
    Member
    Join Date
    Apr 2007
    Location
    Hougang, Singapore
    Posts
    361

    Default Fungus in Digi Cab

    It was a real shock when yesterday i found of my lens having some fungus grown on it. I got that lens 3 months ago, and have always kept in Digi Cab, with humidity around 45%. (Exceptions being when i;m travelling, max is 3 days)....Is it that i need to put it at a lover humidity, of there is something wrong with my handling....Can any body please help me.
    Canon 5D mk II /50 f/1.8, 24-105 f/4 IS L, 70-200 f4 IS L, 580EX II
    My Flickr

  2. #2

    Default Re: Fungus in Digi Cab

    May be you need to recalibrate your Dry Cabinet again...Just to be sure.
    Or get addition gauge to compare the one in the Dry cabinet is correct the same or not..

    As for the lens, whenever I'm back from trip or outting, I'll be use a cleaning cloth to wipe the lens body and for the lens, I using lens cleaning solution and Camera body just use a cleaning cloth to wipe it.

    Hope this will help....

    As for your lens having fungus.. may be you need a solution to clean it..
    if the fungus is outside the lens but is inside the lens... I think have to go back to CSC for servicing....
    Last edited by Rubber_Duck; 3rd June 2008 at 10:23 AM.

  3. #3
    Member
    Join Date
    Apr 2007
    Location
    Hougang, Singapore
    Posts
    361

    Default Re: Fungus in Digi Cab

    Quote Originally Posted by Rubber_Duck View Post
    May be you need to recalibrate your Dry Cabinet again...Just to be sure.
    Or get addition gauge to compare the one in the Dry cabinet is correct the same or not..

    As for the lens, whenever I'm back from trip or outting, I'll be use a cleaning cloth to wipe the lens body and for the lens, I using lens cleaning solution and Camera body just use a cleaning cloth to wipe it.

    Hope this will help....

    As for your lens having fungus.. may be you need a solution to clean it..
    if the fungus is outside the lens but is inside the lens... I think have to go back to CSC for servicing....


    Thanks a lot Rubber_Duck...... may be that my Meter is not indicating the correct value.... i'll try to get to Digi Cab guys to get is re calibrated.....for the fungus, i think it's inside.... so i have to go to Service center....
    Canon 5D mk II /50 f/1.8, 24-105 f/4 IS L, 70-200 f4 IS L, 580EX II
    My Flickr

  4. #4
    Member
    Join Date
    Mar 2004
    Location
    bukit batok
    Posts
    1,478

    Default Re: Fungus in Digi Cab

    1st time i heard of in the dry cabi also can get fungus.
    thanks for the info.

  5. #5

    Default Re: Fungus in Digi Cab

    Is your neck strap moist when you put it inside the cabi?

    Quote Originally Posted by gumnaam View Post
    It was a real shock when yesterday i found of my lens having some fungus grown on it. I got that lens 3 months ago, and have always kept in Digi Cab, with humidity around 45%. (Exceptions being when i;m travelling, max is 3 days)....Is it that i need to put it at a lover humidity, of there is something wrong with my handling....Can any body please help me.

  6. #6
    Senior Member
    Join Date
    Mar 2002
    Location
    Astin Studio
    Posts
    4,736

    Default Re: Fungus in Digi Cab

    Even without dry cabinet or malfunction dry cabinet, it is unlikely for a 3 months old lens to grow fungus, where did u go to shoot with this lens ?

  7. #7
    Member
    Join Date
    Apr 2007
    Location
    Hougang, Singapore
    Posts
    361

    Default Re: Fungus in Digi Cab

    Quote Originally Posted by cereal View Post
    Is your neck strap moist when you put it inside the cabi?
    Yaa... sometimes when it's hot outside, usually i try to dry it up before i keep in, but there are times when i'm in hurry
    Canon 5D mk II /50 f/1.8, 24-105 f/4 IS L, 70-200 f4 IS L, 580EX II
    My Flickr

  8. #8

    Default Re: Fungus in Digi Cab

    Quote Originally Posted by Rubber_Duck View Post
    May be you need to recalibrate your Dry Cabinet again...Just to be sure.
    Or get addition gauge to compare the one in the Dry cabinet is correct the same or not..

    As for the lens, whenever I'm back from trip or outting, I'll be use a cleaning cloth to wipe the lens body and for the lens, I using lens cleaning solution and Camera body just use a cleaning cloth to wipe it.

    Hope this will help....

    As for your lens having fungus.. may be you need a solution to clean it..
    if the fungus is outside the lens but is inside the lens... I think have to go back to CSC for servicing....
    Rubber_Duck, may I know where to get additional gauge? How much does it cost?
    All photographs are there to remind us of what we forget.

  9. #9

    Default Re: Fungus in Digi Cab

    Quote Originally Posted by gumnaam View Post
    Yaa... sometimes when it's hot outside, usually i try to dry it up before i keep in, but there are times when i'm in hurry
    Personally I find it is always better to let it cool down 1st before putting them in. Air them 1st.
    All photographs are there to remind us of what we forget.

  10. #10

    Default Re: Fungus in Digi Cab

    Quote Originally Posted by gumnaam View Post
    Yaa... sometimes when it's hot outside, usually i try to dry it up before i keep in, but there are times when i'm in hurry
    why don't you remove the rubber strap and just store the camera in the dry cabi.
    40 km to 1 litre :p

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •