Results 1 to 4 of 4

Thread: Urgent Question Regarding Digi cabi DB-30

  1. #1

    Default Urgent Question Regarding Digi cabi DB-30

    Hi i know this should fall in the digi cabi thread, but what happened to me just now is really unexpected and i need urgently to know what to do.
    i juz got my digi cabi from lords, just now, when i plug it into my power supply and switch on, i heard a loud spark coming from the back of the digi cabi. anyone know what happened?
    should i try plugging it back and on again or bring it back to lords for 1-1?
    thanks for your help!

  2. #2
    Member
    Join Date
    Jun 2004
    Location
    Singapore
    Posts
    78

    Default Re: Urgent Question Regarding Digi cabi DB-30

    seems like something blown.....better send it back

  3. #3

    Default Re: Urgent Question Regarding Digi cabi DB-30

    at 1st i was thinking, is it the normal start up procedure, well i guess i better send it back tml. i tink i better test at the shop 1st

  4. #4
    Member
    Join Date
    Apr 2008
    Location
    Lakeside, Singapore
    Posts
    289

    Default Re: Urgent Question Regarding Digi cabi DB-30

    Yea. Sounds like something shorted out. Have a look inside and see if the lights are on. If they aren't working then it is dead. Sucks to hear that.
    Cameras: Rollei 35, Rolleiflex-T, FinePix F700, Nikon D60, D300
    Pics: Churchwolf's Album.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •