Results 1 to 5 of 5

Thread: Problem with using 420ex

  1. #1

    Default Problem with using 420ex

    I'm using the canon pro90is and 420ex. The problem i face is that when using the flash, there is a noticeable delay before the flash is fired and the pic taken. This is after doing a half press shutter. Without the flash in use, the pic is taken quite fast. But with the flash in use, the delay always results in the moment being missed. Whats the problem?

  2. #2

  3. #3
    Senior Member
    Join Date
    Jan 2002
    Location
    Singapore
    Posts
    12,938

    Default

    is it due to the pre-flash?
    Check out my wildlife pics at www.instagram.com/conrad_nature

  4. #4

    Default

    Yes, the pre-flash used by the E-TTL system is the problem. Well documented in dpreview. The "brain" of cameras like Pro90IS and G series is slower than that of DSLR's. So after the pre-flash, it takes longer to calculate how much the flash output should be. It can be up to one second delay, which is enough time for your subject to blink because of the pre-flash. Very irritating.

    One workaround is to use the FEL button (not sure whether Pro90IS has this - it's usually the button with an asterisk "*"). This will fire the pre-flash and lock the flash exposure setting. The next time you press the shutter, it should fire immediately without delay.

  5. #5

    Default

    Originally posted by StreetShooter
    Yes, the pre-flash used by the E-TTL system is the problem. Well documented in dpreview. The "brain" of cameras like Pro90IS and G series is slower than that of DSLR's. So after the pre-flash, it takes longer to calculate how much the flash output should be. It can be up to one second delay, which is enough time for your subject to blink because of the pre-flash. Very irritating.

    One workaround is to use the FEL button (not sure whether Pro90IS has this - it's usually the button with an asterisk "*"). This will fire the pre-flash and lock the flash exposure setting. The next time you press the shutter, it should fire immediately without delay.

    ooh okies, yeah, there's a FEL.. i'll try to test it later. Thanks!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •