Results 1 to 7 of 7

Thread: 40D went blank

  1. #1

    Default 40D went blank

    have anyone suffered the trauma of 40D went blank in the midst of my event shoot. Battery was fully charged. Just cant get it on. removed battery, lens and all. after a short while everything got back as normal and i continued my shoot. I still dont know the reason. help...

  2. #2
    Senior Member dennisc's Avatar
    Join Date
    Oct 2002
    Location
    Freezing Upp Thomson/Mandai!
    Posts
    2,012

    Default Re: 40D went blank

    40D prob fainted from the heat .
    But who cares since yours is fine now. I only get blanks when I shot in extremes (settings). Overheated the sensor so poof blank for awhile.

  3. #3

    Default Re: 40D went blank

    Scary, but with any electronics, sudden failure can happen anytime and anywhere. If the event or shoot is important, try to carry a second body as a back-up. If cannot afford a second body, charge a bit more and rent one. No matter what happens, if you cannot shoot anymore at important events, even if you give full refund, the client will never be happy and will always bad-mouth you.

  4. #4
    Senior Member
    Join Date
    Sep 2007
    Location
    Serangoon North
    Posts
    2,225

    Default Re: 40D went blank

    Quote Originally Posted by Dream Merchant View Post
    Scary, but with any electronics, sudden failure can happen anytime and anywhere. If the event or shoot is important, try to carry a second body as a back-up. If cannot afford a second body, charge a bit more and rent one. No matter what happens, if you cannot shoot anymore at important events, even if you give full refund, the client will never be happy and will always bad-mouth you.
    I wondered if anyone has encountered camera failure, no backup cam and starts to use their handphone camera to shoot instead..

  5. #5

    Default Re: 40D went blank

    Is yours a new camera and new battery? Don't worry nothing is wrong, new batteries will tend to exhibit this sort of behaviour. Can't remember the reason but after using the battery and charging it for a few more cycles the problem will go away by itself. Happened to me before as well.

  6. #6

    Default Re: 40D went blank

    Ah...so it could be only a batt problem? That's good to hear.

  7. #7

    Default Re: 40D went blank

    That is definitely a good newz. Hope it does not happen too often. Thanks again..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •