Results 1 to 14 of 14

Thread: digi-cabi no lights

  1. #1

    Default digi-cabi no lights

    hi all. as above. what could happened?
    Theres no green / red lights at all !! ...
    been using this for at lease 3 yrs ... should I repair or buy another one ?
    Last edited by copikau; 14th September 2007 at 08:53 AM.

  2. #2

    Default Re: digi-cabi no lights

    geez .. no one ? ... so I guess it died on me ...

  3. #3
    Member
    Join Date
    Jul 2007
    Location
    Kovan
    Posts
    213

    Default Re: digi-cabi no lights

    Quote Originally Posted by copikau View Post
    geez .. no one ? ... so I guess it died on me ...
    ehh. no green light when u turn the knot towards the extreme right?

  4. #4

    Default Re: digi-cabi no lights

    turned knob all to extreme right. still no green light

  5. #5
    Senior Member roadrunner_552's Avatar
    Join Date
    Aug 2005
    Location
    East
    Posts
    2,516

    Default Re: digi-cabi no lights

    mine light always onz. Not sure what is the problem for you. Maybe u can give digi-cabi a call?

  6. #6
    Member
    Join Date
    Nov 2004
    Location
    Somewhere in little red dot
    Posts
    538

    Default Re: digi-cabi no lights

    What is the meter indicating? Normal or High %RH?

  7. #7
    Member
    Join Date
    Sep 2007
    Location
    LA 2019
    Posts
    1,282

    Default Re: digi-cabi no lights

    you have a multimeter? check the electronics..

  8. #8
    Member
    Join Date
    Jul 2007
    Location
    In the East
    Posts
    444

    Default Re: digi-cabi no lights

    if still under warranty... do give digihub a call~
    Canon 400D + 50L - Everyone was once a Noob

  9. #9

    Default Re: digi-cabi no lights

    i think still ok. my knob till 3/4 then a bit lite up only . using the AD 60.

  10. #10
    Senior Member
    Join Date
    Jan 2002
    Location
    Singapore
    Posts
    12,938

    Default Re: digi-cabi no lights

    if the humidity remains low, it means that the digicab is still working... so might not need to do anything.

  11. #11
    Senior Member
    Join Date
    Oct 2005
    Location
    North
    Posts
    2,703

    Default Re: digi-cabi no lights

    My digicab is either green or red. What is your humidity now and after opening the door? If it still falls back to the predefined level, then its still working!
    Canon 5D mkII|24-105 F4 IS L|70-200 F4 IS L|135 F2 L|580EX|

  12. #12

    Default Re: digi-cabi no lights

    reading at 76% 26'C ...

    warranty expired.

  13. #13
    Member
    Join Date
    Dec 2005
    Location
    cockroach-infested parsee lees
    Posts
    1,328

    Default Re: digi-cabi no lights

    Quote Originally Posted by copikau View Post
    reading at 76% 26'C ...

    warranty expired.
    that sounds like s'pore humidity and night temp. chances are the dehumidifier unit is gone... call digi-cab, the cost of replacing the unit shd be cheaper than buying a new set.
    Many are culled, few are chosen

  14. #14
    Senior Member
    Join Date
    Oct 2005
    Location
    North
    Posts
    2,703

    Default Re: digi-cabi no lights

    Yea just get a new one la. But its kinda odd that the cab just last slightly over a year?!
    Canon 5D mkII|24-105 F4 IS L|70-200 F4 IS L|135 F2 L|580EX|

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •