Results 1 to 15 of 15

Thread: EOS 20D .... newbies ..

  1. #1

    Default EOS 20D .... newbies ..

    just got my 20D .. and playing with it ..

    got one funny problem is when switching to "Basic Zone Modes"..
    turning the dial to "Full Auto", depress the shutter button .. expecting the lens to focus but instead heard a funny "rattling" sound .. lens didnt response and got a "error msg" appear on the menu window (the one next to the shutter button) ..then have to OFF and ON again.

    It works fine when run on "Creative Zone Modes" ..

    Is there any setting that i need to do ? Or ... eerrrr .. my 20D body is defective ...

    Advice please ...

  2. #2
    Member
    Join Date
    Jul 2007
    Location
    Singapore
    Posts
    491

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by Westdan View Post
    just got my 20D .. and playing with it ..

    got one funny problem is when switching to "Basic Zone Modes"..
    turning the dial to "Full Auto", depress the shutter button .. expecting the lens to focus but instead heard a funny "rattling" sound .. lens didnt response and got a "error msg" appear on the menu window (the one next to the shutter button) ..then have to OFF and ON again.

    It works fine when run on "Creative Zone Modes" ..

    Is there any setting that i need to do ? Or ... eerrrr .. my 20D body is defective ...

    Advice please ...
    You bought brand new of second hand? 20D is an very old model and no longer in production nor available in the market already, but it's still a very good camera nonetheless. I'm a 20D user also.

    Have you check the camera before you buy it? What's the error message appeared?

    So far, my don't have such problem...

  3. #3

    Default Re: EOS 20D .... newbies ..

    Thanks Boredad .. is a 2nd hand .. bought thru this forum .. check thru but not so thorough .. only test out the "Creative Zone Modes" ..

    Just try again ... the error msg appears read "ERR 05" ... and blinking ..

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    North
    Posts
    2,703

    Default Re: EOS 20D .... newbies ..

    Oh oh....
    Canon 5D mkII|24-105 F4 IS L|70-200 F4 IS L|135 F2 L|580EX|

  5. #5

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by Westdan View Post
    Thanks Boredad .. is a 2nd hand .. bought thru this forum .. check thru but not so thorough .. only test out the "Creative Zone Modes" ..

    Just try again ... the error msg appears read "ERR 05" ... and blinking ..
    To add on .. the problem only appear when i switch the dial to "FULL AUTO" and "PORTRAIT" .. the others are ok ..

  6. #6
    Member
    Join Date
    Jul 2007
    Location
    Singapore
    Posts
    491

    Default Re: EOS 20D .... newbies ..

    Hmm... Try this:

    Off the power, remove the battery, then leave it like this for about 2 to 3 minutes, then put the battery back then try again to see how. Or you may want to change to a new battery and try again.

    If the problem still persist, then the next best alternative is to bring the camera down to the Canon Servcing Center to have it check out.

    Or unless you think you can accept this problem and if you are going to use the creative zone more often than the programmed zone, then I think it's still OK. Cause when you are using the programmed zones, you can't do any changes in the setting of the camera, so best is to use the creative zones more often, which gives you nearly full control of how you want to take the photos and the kind of result you need.

  7. #7

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by Westdan View Post
    just got my 20D .. and playing with it ..

    got one funny problem is when switching to "Basic Zone Modes"..
    turning the dial to "Full Auto", depress the shutter button .. expecting the lens to focus but instead heard a funny "rattling" sound .. lens didnt response and got a "error msg" appear on the menu window (the one next to the shutter button) ..then have to OFF and ON again.

    It works fine when run on "Creative Zone Modes" ..

    Is there any setting that i need to do ? Or ... eerrrr .. my 20D body is defective ...

    Advice please ...
    issit error 5? looks like ur flash stuck sia. my 400D is gaffered to the extent that the pop up flash cant work. so on the green mode the camera will hang because the flash cant come up. try pressing the flash button and see if ur flash can come up a not. if can't that means flash release lock spoil lor.

    not to worry. use external flash. more flattering results lol.
    Last edited by wanzw; 12th September 2007 at 06:22 AM.
    random equipment.
    where are my primes?

  8. #8

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by Bored Dad View Post
    Hmm... Try this:

    Off the power, remove the battery, then leave it like this for about 2 to 3 minutes, then put the battery back then try again to see how. Or you may want to change to a new battery and try again.

    If the problem still persist, then the next best alternative is to bring the camera down to the Canon Servcing Center to have it check out.

    Or unless you think you can accept this problem and if you are going to use the creative zone more often than the programmed zone, then I think it's still OK. Cause when you are using the programmed zones, you can't do any changes in the setting of the camera, so best is to use the creative zones more often, which gives you nearly full control of how you want to take the photos and the kind of result you need.

    Thanks Boredad ... will try out again and probably may need a trip to the service center..

  9. #9

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by wanzw View Post
    issit error 5? looks like ur flash stuck sia. my 400D is gaffered to the extent that the pop up flash cant work. so on the green mode the camera will hang because the flash cant come up. try pressing the flash button and see if ur flash can come up a not. if can't that means flash release lock spoil lor.

    not to worry. use external flash. more flattering results lol.
    Well.. as a matter of fact .. indeed the previous owner have gaffered up almost the whole body and likewise on the in-build flash ... he used to run on external flash ..

    Do you mean that i should remove the gaffer tape on in-build flash to try out again ?

  10. #10
    Member/Tangshooter Redsun's Avatar
    Join Date
    Nov 2005
    Location
    Singapore
    Posts
    7,931

    Default Re: EOS 20D .... newbies ..

    you should.That might be the problem

  11. #11
    Senior Member
    Join Date
    Jan 2003
    Location
    Dry cabinet!
    Posts
    1,757

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by Westdan View Post
    just got my 20D .. and playing with it ..

    got one funny problem is when switching to "Basic Zone Modes"..
    turning the dial to "Full Auto", depress the shutter button .. expecting the lens to focus but instead heard a funny "rattling" sound .. lens didnt response and got a "error msg" appear on the menu window (the one next to the shutter button) ..then have to OFF and ON again.

    It works fine when run on "Creative Zone Modes" ..

    Is there any setting that i need to do ? Or ... eerrrr .. my 20D body is defective ...

    Advice please ...
    camera is making built-in flash pop up, but it can't pop up and hence makes such sound.
    If the built-in flash is able to pop up without obstruction, you will no have the problem.
    Dreaming... 14mm f2.8, 16-35 f2.8 mkII, 85 f1.2 mkII

  12. #12

    Default Re: EOS 20D .... newbies ..

    hello Bored Dad/yehosaphat/wanzw/Redsun and gryhon ... thanks for your tips .. i finally solve the mystery .. ya ... the gaffer tape is running over the build-in and hence is causing obstruction ...

    sorry for the false alarm ... soli ... soli ...

    thanks guys ...

  13. #13

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by Westdan View Post
    hello Bored Dad/yehosaphat/wanzw/Redsun and gryhon ... thanks for your tips .. i finally solve the mystery .. ya ... the gaffer tape is running over the build-in and hence is causing obstruction ...

    sorry for the false alarm ... soli ... soli ...

    thanks guys ...
    no problems. dun use built in... external.
    random equipment.
    where are my primes?

  14. #14

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by wanzw View Post
    no problems. dun use built in... external.

    Yup ... external flash will be the next on my list ... $$$$$ ... hehe ..

  15. #15
    Member
    Join Date
    Jul 2007
    Location
    Singapore
    Posts
    491

    Default Re: EOS 20D .... newbies ..

    Quote Originally Posted by Westdan View Post
    hello Bored Dad/yehosaphat/wanzw/Redsun and gryhon ... thanks for your tips .. i finally solve the mystery .. ya ... the gaffer tape is running over the build-in and hence is causing obstruction ...

    sorry for the false alarm ... soli ... soli ...

    thanks guys ...
    It's OK and you're most welcome. Glad to know it's just a false alarm and no serious problem with the camera. Enjoy your shoots then.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •