Results 1 to 5 of 5

Thread: Splotch on K10D pictures...

  1. #1

    Default Splotch on K10D pictures...

    There is a spot on the picture shot againt a piece of white paper. I bought my K10D on last Sunday and have taken just a few shots.

    Could it be dust on the lens or on the sensor? If it is on the lens, I can probably wipe it off. But what if it's on the CCD?

    This is my first DSLR. And I am an absolute rookie. Can anyone help me on this? It will be really appreciated!


    Even with the normal settings, it is a bit obvious already.



    The same picture after the exposure was increased with a simple editing tool, bloody hell!
    Last edited by Elutitti; 19th July 2007 at 05:22 PM.

  2. #2

    Default Re: Splotch on K10D pictures...

    It is caused by dust on your sensor.

  3. #3

    Default Re: Splotch on K10D pictures...

    Quote Originally Posted by Kin View Post
    It is caused by dust on your sensor.
    Thanks Kin.

    Any solution?

  4. #4

    Default Re: Splotch on K10D pictures...

    Quote Originally Posted by Elutitti View Post
    Thanks Kin.

    Any solution?
    Put mirror to up position from menu, use blower to blow at sensor. Hopefully dust will be removed.
    Pentax K-5 K10D ME FA35 50f1.4 DA12-24 DA17-70, Tamron 70-200, Polar 85f1.4, Sigma 17-70
    My Flickr

  5. #5

    Default Re: Splotch on K10D pictures...

    Quote Originally Posted by CY_OH View Post
    Put mirror to up position from menu, use blower to blow at sensor. Hopefully dust will be removed.
    Thanks.. I'll try it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •