Results 1 to 5 of 5

Thread: Question after I got my tripod

  1. #1

    Default Question after I got my tripod

    Hi all,

    Tried to search in the forums but cannot find the relevent answers.
    I have a D70s with 18-200mm. I recently just bought a Benro A-158 with BH00 ball head.

    Everything works fine on this tripod when I place by camera in the normal position (lanscape), but I turn the camera to the vertical (potrait) position, I am seeing the camera started to rotate (slip) with the quick release plate. This actually causing me unable to take picture with potrait position with certain angle tilted to an angle.

    I check the screw under the quick release plate already being tighten.I guess the friction between the camera base and the quick release plate is very little.

    I hope my problem is clear to you guys. How can I overcome this? Do I need to get another tripod head? Or anything I miss out?

    Thanks...Lew

  2. #2

    Default Re: Question after I got my tripod

    Quote Originally Posted by metta1013 View Post
    Hi all,

    Tried to search in the forums but cannot find the relevent answers.
    I have a D70s with 18-200mm. I recently just bought a Benro A-158 with BH00 ball head.

    Everything works fine on this tripod when I place by camera in the normal position (lanscape), but I turn the camera to the vertical (potrait) position, I am seeing the camera started to rotate (slip) with the quick release plate. This actually causing me unable to take picture with potrait position with certain angle tilted to an angle.

    I check the screw under the quick release plate already being tighten.I guess the friction between the camera base and the quick release plate is very little.

    I hope my problem is clear to you guys. How can I overcome this? Do I need to get another tripod head? Or anything I miss out?

    Thanks...Lew
    Well...Think I found some info on this....thread can be closed. But still welcome your comment.

  3. #3

    Default Re: Question after I got my tripod

    Hehe, Jack would tell you to add a washer in between the QR plate and the camera, where you screw in, it worked for me.

    If you need washers I can spare if you live in the East, but it's pretty cheap, $1 for a big packet from any bike shop.. =)

  4. #4

    Default Re: Question after I got my tripod

    Perhaps share the info for people who have this problem in the future
    It is the camera, not the photographer.
    my flickr - adamloh.com

  5. #5

    Default Re: Question after I got my tripod

    Maybe cannot support your cam weight?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •