Results 1 to 2 of 2

Thread: sunpak ringlite w FZ-50?

  1. #1

    Default sunpak ringlite w FZ-50?

    hey guys, i havent used an ext flash before
    just wondering if sunpak's ringlites work with the FZ-50. Coz i tried one last time and it didnt fire and the store manageable didnt know much about FZ-50 also, so i was worried that the hotshoe was defective or sth, are there any settings i have to change before the Flash is able to shoot?

    thanks and cheers!

  2. #2
    Deregistered
    Join Date
    May 2006
    Location
    Somewhere by the sea...
    Posts
    473

    Default Re: sunpak ringlite w FZ-50?

    Hmm....without seeing the situation for myself there is a few things I can think of

    a) Make sure the the center pin (X-Sync) is aligned with the terminal on the FZ50
    b) press the right arrow button after you turn on BOTH the cam and the ring flash/ ring light, set the setting to FORCE FLASH ON (I don't think the SUNPak provides TTL control so the other options won't even appear on the flash menu)
    c) Or, check your menu, external flash setting and play around with either preset (will fix your aperture at F4) or manual.

    Thats all I can think of at the moment....Unless its a pretty old ringflash you are trying out here in which this case better check out the trigger voltage as older flash have higher trigger voltages that can damage hotshoes...Hope this will help
    Last edited by rapier84; 19th March 2007 at 10:24 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •