Results 1 to 5 of 5

Thread: Need help with Klipsch Promedia 4.1

  1. #1
    Senior Member
    Join Date
    Apr 2004
    Location
    Beeshan
    Posts
    1,830

    Default Need help with Klipsch Promedia 4.1

    Hi

    I have a Klipsch Promedia 4.1, seems like the control unit is spoiled or stuck, whatever it is, I just cant power it on.

    Does anyone here know where i can repair it? or have the skills to repair it?

    Thanks

  2. #2
    Member
    Join Date
    Oct 2002
    Location
    Singapore - Jurong West
    Posts
    807

    Default Re: Need help with Klipsch Promedia 4.1

    check if the pins for your connector are all straight? Did you unplug and replug it recently?

  3. #3
    Senior Member
    Join Date
    Apr 2004
    Location
    Beeshan
    Posts
    1,830

    Default Re: Need help with Klipsch Promedia 4.1

    erm, there is this knob for the volume as well as power. somehow it seems stuck. any idea how to fix it?

  4. #4
    Member
    Join Date
    Jan 2002
    Location
    ClubSNAP East
    Posts
    1,702

    Default Re: Need help with Klipsch Promedia 4.1

    Sure it's only the power knob and not the sub? If the latter, haiz...

    :Later,

  5. #5
    Senior Member
    Join Date
    Apr 2004
    Location
    Beeshan
    Posts
    1,830

    Default Re: Need help with Klipsch Promedia 4.1

    yea. pretty sure its just the knob

    any ideas?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •