Results 1 to 7 of 7

Thread: HELP! Lens closes down and stays that way!!!

  1. #1

    Default HELP! Lens closes down and stays that way!!!

    This has got me stumped.

    My Sigma 15-30mm lens on my 10D stops down and remains that way after a few shots.

    It doesn;t appear to be the camera as none of the other lenses behave like this.

    I have totally reformatted everything - cf card, camera, took out camera 'internal clock' batt and put back but same thing still.

    The only thing that helps is if I switch off the cam, take off the lens, replace with another lens and shoot, then switch back to the Sigma lens...after awhile. When I first take the Sigma lens off, the apeture remains closed. Sometimes, I have to take off-switch-wait-put back on-take off a few times then it works. Also, sometimes switching the lens between AF and MF helps to get the lens back into working order.

    Any ideas as to what is happening, and what I should do?

  2. #2

    Default Re: HELP! Lens closes down and stays that way!!!

    Sounds like lens incompatibility, or else it's a lens fault.
    Best to just bring it to Sigma (service centre at Jln Bukit Merah) for servicing.

  3. #3
    Senior Member
    Join Date
    Jan 2002
    Location
    South Pole with Penguin
    Posts
    5,270

    Default Re: HELP! Lens closes down and stays that way!!!

    if it has been working fine, the aperture blades may refuse to open if they got jammed due to oil or dirt

    i use Sigma 15-30 with D30 & 10D before, so shouldnt be incompatibility problem
    We are HDD of PC & FT are MB add to storage;
    so PC never hangs with enormous storage capacity - LKY

  4. #4

    Default Re: HELP! Lens closes down and stays that way!!!

    Quote Originally Posted by Feinwerkbau
    This has got me stumped.

    My Sigma 15-30mm lens on my 10D stops down and remains that way after a few shots.

    It doesn;t appear to be the camera as none of the other lenses behave like this.

    I have totally reformatted everything - cf card, camera, took out camera 'internal clock' batt and put back but same thing still.

    The only thing that helps is if I switch off the cam, take off the lens, replace with another lens and shoot, then switch back to the Sigma lens...after awhile. When I first take the Sigma lens off, the apeture remains closed. Sometimes, I have to take off-switch-wait-put back on-take off a few times then it works. Also, sometimes switching the lens between AF and MF helps to get the lens back into working order.

    Any ideas as to what is happening, and what I should do?
    "Swollen" liow. Could be due to greasy aperture blades, send it in for servicing.

  5. #5

    Default Re: HELP! Lens closes down and stays that way!!!

    Not really sure if sticky or oily.

    Mount lens on, apeture big big.

    Set cam on manual, say f 5.6 or 8, shoot a few, then lens closes right down to the very min (22-27). Sometimes, it like goes from wide open to say around 11 (eventhough the lens is set at 5.6) then subsequently darkens to the very minimum.

    If it's sticky, it should stick at the set 5.6 or 8 correct?

  6. #6

    Default Re: HELP! Lens closes down and stays that way!!!

    Check with sigma service center your motor might be spoilt already.

  7. #7

    Default Re: HELP! Lens closes down and stays that way!!!

    Might be some compatibility problem, have similar problem with a old sigma lens previously.

    When it get stuck, either do what u have mentioned or choose aperture priority, set aperture wide open and press DOF preview a few times, sometimes it will open back up again..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •