Results 1 to 4 of 4

Thread: Power Surge on the Hub Port

  1. #1
    Member
    Join Date
    Jun 2005
    Location
    Hard to keep track
    Posts
    69

    Default Power Surge on the Hub Port

    Hi guys

    Im facing this problem with my FZ-20 recently, everytime when I try to connect
    my cam to a pc it always promnt me this

    Power Surge on the Hub Port"
    A USB device has exceeded the power limits of its hub port.


    What seems to be the main problem?

    Thanks in advance

  2. #2

    Default Re: Power Surge on the Hub Port

    :Hi Trey ..i also got this problem..if i'm not wrong (i'm not a computer expert)..your PC USB port is a slower verison 1....
    :i experience this when i plug in any USB related stuff (like tumbdrives/camera cable/printer)..and my PC doesn't detect it , keep giving this stupid warning message....
    :and sometimes never plug in anything also this message will appear...
    :my solution to this is ...shut down your PC....plug in your USB stuff(your camera with cable in this scenario...) turn on the camera ....then turn on your PC.....it works for me but dun noe whether works for you or not...??
    :another solution...that my fren recommend is to get a faster USB port (i dun noe what this device is called, forgot liao)..but i haven't try yet...
    :if anybody else got the proper solution to help us ..pls advise us too...

    Regards

  3. #3

    Default Re: Power Surge on the Hub Port

    your hub cannot supply enough power to the camera.

    Get a hub that has an external power supply.

  4. #4

    Default Re: Power Surge on the Hub Port

    Quote Originally Posted by AReality
    your hub cannot supply enough power to the camera.

    Get a hub that has an external power supply.
    maybe...

    try to get a reader...
    Stress Man @ work... :bigeyes:

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •