Results 1 to 8 of 8

Thread: Intermitten colour cast

  1. #1
    Member
    Join Date
    Nov 2010
    Location
    Queenstown
    Posts
    105

    Default Intermitten colour cast

    Name:  Colour cast 01.jpg
Views: 0
Size:  52.7 KB
    Been using my K500 for 3 months without any problems. Today took some shots of a cosplay event at Downtown East. The rain stop & the skies overcast. Took about 50 shots & suddenly some pics got reddish/cyan colour cast intermittenly. I tried changing iso from 200 to 100, shutter speed & F stop & still it happen once every few shots. Using my Pentax 16-50mm on manual mode & a Metz flashgun also on manual with 1/4 power ratio with diffuser. The affected pics can be edited easily but what caused this colour cast? Hope it's not the camera problem

  2. #2

    Default

    Quote Originally Posted by Tonistein View Post
    <img src="http://www.clubsnap.com/forums/attachment.php?attachmentid=5983"/>
    Been using my K500 for 3 months without any problems. Today took some shots of a cosplay event at Downtown East. The rain stop & the skies overcast. Took about 50 shots & suddenly some pics got reddish/cyan colour cast intermittenly. I tried changing iso from 200 to 100, shutter speed & F stop & still it happen once every few shots. Using my Pentax 16-50mm on manual mode & a Metz flashgun also on manual with 1/4 power ratio with diffuser. The affected pics can be edited easily but what caused this colour cast? Hope it's not the camera problem
    Did you leave your white balance on auto?

  3. #3
    Member
    Join Date
    Nov 2010
    Location
    Queenstown
    Posts
    105

    Default Re: Intermitten colour cast

    Yes. Metering centre weighted. I didn't change any setting from Day 1. I don't like to use Auto mode or P for shooting with flashgun

  4. #4
    Moderator catchlights's Avatar
    Join Date
    Sep 2004
    Location
    Punggol, Singapore
    Posts
    21,902

    Default Re: Intermitten colour cast

    Quote Originally Posted by Tonistein View Post
    Name:  Colour cast 01.jpg
Views: 0
Size:  52.7 KB
    Been using my K500 for 3 months without any problems. Today took some shots of a cosplay event at Downtown East. The rain stop & the skies overcast. Took about 50 shots & suddenly some pics got reddish/cyan colour cast intermittenly. I tried changing iso from 200 to 100, shutter speed & F stop & still it happen once every few shots. Using my Pentax 16-50mm on manual mode & a Metz flashgun also on manual with 1/4 power ratio with diffuser. The affected pics can be edited easily but what caused this colour cast? Hope it's not the camera problem
    Quote Originally Posted by Tonistein View Post
    Yes. Metering centre weighted. I didn't change any setting from Day 1. I don't like to use Auto mode or P for shooting with flashgun
    that is how auto white balance works isn't it?
    the camera measure the scene and determine what is the "best" color balance for this particular scene, so the white balance is not FIXED from picture to picture if the setting is changed.

    for an instant here, there is no light source or highlight captured in the photos,
    first pix, more green and blue in the photo and flash is only quarter power from a further distance, so the photo bias towards magenta.

    second pix, less blue and green in the photo, and flash is same power but at a shorter distance, so the camera determine this is a "better" white balance.

    noting wrong with your camera. the issue lies outside the camera.
    Shoot to Live, Live to Shoot
    www.benjaminloo.com | iStock portfolio

  5. #5
    Member SyncGuy's Avatar
    Join Date
    Sep 2011
    Location
    Earth
    Posts
    1,118

    Default

    Yea... Spot on with regards to the issue: AWB.

    Manual WB would be better but of course, just a short work in LR can already.

    Meanwhile, another tip for you in the future, when shooting indoor or anywhere with artificial lighting as your dominant light (not you strobe), try to keep the shutter speed above 1/60.

    This is because Singapore's AC power is 60hz, meaning 1/60. And if you shoot slower than 1/60, you will notice that your image will have differing color cast, even with manual WB selected.

    This is coz the light bulb is flickering at 1/60.

    :B
    Pentax Kr, Pentax Super A
    K105/2.8, Fa*24/2, A28/2, A35/2, A50/1.4, A*85/1.4, A100/2.8, A135/2.8

  6. #6
    Senior Member shierwin's Avatar
    Join Date
    Dec 2008
    Location
    East Coast
    Posts
    3,320

    Default Re: Intermitten colour cast

    Quote Originally Posted by catchlights View Post

    ...nothing wrong with your camera. the issue lies outside the camera.
    Diplomatic answer

  7. #7
    Member
    Join Date
    Nov 2010
    Location
    Queenstown
    Posts
    105

    Default Re: Intermitten colour cast

    Quote Originally Posted by catchlights View Post
    that is how auto white balance works isn't it?
    the camera measure the scene and determine what is the "best" color balance for this particular scene, so the white balance is not FIXED from picture to picture if the setting is changed.

    for an instant here, there is no light source or highlight captured in the photos,
    first pix, more green and blue in the photo and flash is only quarter power from a further distance, so the photo bias towards magenta.

    second pix, less blue and green in the photo, and flash is same power but at a shorter distance, so the camera determine this is a "better" white balance.

    noting wrong with your camera. the issue lies outside the camera.
    Normal situation I agree but I am using flash. So far I have shot 5000+ with this camera & many times in low light with flash. Nothing like this ever happen. Maybe the lighting yesterday was way too low & my flash power ratio is 1/4. Never thought of increasing the ratio to 1/2. Anyway going for the event again today & see whether such thing will happen again or not. The weather much better than yesterday

  8. #8
    Moderator catchlights's Avatar
    Join Date
    Sep 2004
    Location
    Punggol, Singapore
    Posts
    21,902

    Default

    Quote Originally Posted by Tonistein View Post
    Normal situation I agree but I am using flash. So far I have shot 5000+ with this camera & many times in low light with flash. Nothing like this ever happen. Maybe the lighting yesterday was way too low & my flash power ratio is 1/4. Never thought of increasing the ratio to 1/2. Anyway going for the event again today & see whether such thing will happen again or not. The weather much better than yesterday
    Just go and check the exif and compare the exposure of those shots you mention you will know the lighting level.

    Btw, 5000 shots over a three months is not very little for a hobbylist, you should able to understand photography and your camera pretty well by now.
    Shoot to Live, Live to Shoot
    www.benjaminloo.com | iStock portfolio

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •