Results 1 to 3 of 3

Thread: Camera / Batteries Problem???

  1. #1
    Member
    Join Date
    Jun 2004
    Location
    Singapore, Toa Payoh Nth
    Posts
    146

    Unhappy Camera / Batteries Problem???

    Recently found that all(3 set) my fully charge batteries when put into my cam cannot last long. After power On for awhile & take a few shot, the cam show low batt sign. Which is at fault(problem)? Advise.

    THks & RGds

  2. #2
    Member
    Join Date
    May 2004
    Location
    my house
    Posts
    315

    Default

    it might be cause by the fault camera sensor.
    Nikon D5000, D70; Nikon 18-55, 18-70, 70-300; Sigma 18-250, 50-500.

  3. #3
    Member
    Join Date
    Jun 2004
    Location
    Singapore, Toa Payoh Nth
    Posts
    146

    Default

    Quote Originally Posted by coldman
    it might be cause by the fault camera sensor.
    So u mean my cam is having problem.
    Last Sat(30/7/05) was @ the shear bridge to shoot the NDP preview fireworks. Initially I have insert one set of fully charge Sanyo Ni-MH rechargable batteries but when shooting a few scenery shot, the low batt sign lit up. Quickly replaced with my spare CR-V3 lithium battery pack before the fireworks start. lucky I was able the shoot through out the whole fireworks display. Do u think all my 3set of rechargable batteries were spoil. Advise. Thks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •