Results 1 to 11 of 11

Thread: Need some help on my digital cabinet

  1. #1

    Default Need some help on my digital cabinet

    Recently my friend give a samurai brand digital cabinet as a gift. I seem to had a problem setting the RH. The manual stated press the "set" button for 3 sec and when the screen blink key in the number you want to set the RH from the up or down button, after keying the number press the "set" button again to confirm the setting. I try doing it a few times already but once I press the "set" button to confirm, the RH goes back to 70+ just like factory default. I wonder any csers here use this brand before and care to share with me is the way I set correct or the cabinet has defect. I myself had 2 cabinet but not fully digital so I never encounter this before. Please advise me on this.
    Thank you.

  2. #2

    Default

    I'm using this same brand. It shows 70+ coz it is showing the current RH level. Wait awhile and you'll see the RH level to slowly decrease.

  3. #3
    Moderator ed9119's Avatar
    Join Date
    Mar 2002
    Location
    Singapore
    Posts
    10,931
    Blog Entries
    26

    Default Re: Need some help on my digital cabinet

    give it a couple of hours before seeing what the true reading is

    it needs time
    shaddap and just shoot .... up close
    Walkeast

  4. #4

    Default

    Thanks for the reply guys. I just check the RH level before I left for work this morning. The RH level still stays at 70+. Is the way I do the setting correct or it really takes times for the RH to decrease? Please advise. Thanks.

  5. #5
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,389

    Default Re: Need some help on my digital cabinet

    Quote Originally Posted by Gikens View Post
    Thanks for the reply guys. I just check the RH level before I left for work this morning. The RH level still stays at 70+. Is the way I do the setting correct or it really takes times for the RH to decrease? Please advise. Thanks.
    After a few hours you will see already lower reading. In case there is no change in the reading after a day, there are two possible options:
    a) Cabinet not working (did you plug it into wall socket? Switched on?)
    b) Something is wrong with the way you set the target RH.
    I can only comment on a) since I don't have this cabinet. Check the socket and everything else to make sure it's powered. Open the door, locate the dehumidifier unit and check whether it feels cold. To locate the little unit check the image this older posting. Yours might look a bit different, but it's a small black box at the back. There is an opening of the plastic cover on top, use your finder to check the metal element inside. (No worries, you won't get any shock.) If the metal does not feel distinctively cold then it's not working. Now, before you jump at your friend and call him something that your grandmother would not approve please bear in mind that nothing lasts forever. These units give way after some time, that's normal. If it's concluded that the unit is faulty please contact the service partner.
    You might not need to lug around the entire cabinet to the service center. Just use a screwdriver to unmount the black box (4-6 screws) and bring it in.
    EOS

  6. #6

    Default

    Hey guys.. Thanks a lot for all the reply and advise. The RH level still stay at 70+ after so many days. I have already call up the dealer and they have confirm me that the cabinet could be faulty and will do a 1 to 1 exchange with me. Hopefully there are ways to test it on the spot so that I don't have to waste time and money on transport to travel here and there.

  7. #7
    Moderator keithwee's Avatar
    Join Date
    Aug 2010
    Location
    LittleRedDot
    Posts
    7,889

    Default

    Quote Originally Posted by Gikens View Post
    Hey guys.. Thanks a lot for all the reply and advise. The RH level still stay at 70+ after so many days. I have already call up the dealer and they have confirm me that the cabinet could be faulty and will do a 1 to 1 exchange with me. Hopefully there are ways to test it on the spot so that I don't have to waste time and money on transport to travel here and there.
    Don't know of anyway to test on the spot but it definitely should be well adjusted after a few hours. ; don't need a few days

    Glad that u have gotten a 1-1 xchange

  8. #8

    Default

    Quote Originally Posted by Gikens View Post
    Hopefully there are ways to test it on the spot so that I don't have to waste time and money on transport to travel here and there.
    The way the drier works is to create a cold surface which condenses the moisture out of the air in the cabinet.

    Turn on the unit and reach into the drier unit with your finger and you should be able to feel the plate turning cold.

  9. #9
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,389

    Default Re: Need some help on my digital cabinet

    Quote Originally Posted by Gikens View Post
    Hopefully there are ways to test it on the spot so that I don't have to waste time and money on transport to travel here and there.
    Exactly the same way as I have described earlier. Connect the unit to power, switch on and check whether the metal surface gets cold. If it does then it is working fine.
    EOS

  10. #10

    Default

    Noted. Thanks guys.

  11. #11

    Default

    I just got the dry cabinet 1 to 1 exchange today. It working fine now.
    Thanks guys.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •