Results 1 to 7 of 7

Thread: Phottix strato II setting

  1. #1

    Default Phottix strato II setting

    I just gotten 1 set of the triggers today and tested all functions to work properly except when the receiver mounted on hotshoe with 430ex II on top of it to serve as wireless/wired shutter, the trigger work as per normal but the fire doesn't fire.

    Is it because the flash not being supported for this feature?

    I couldn't find any info regarding this, hence hope to seek advices here.

    Thanks!

  2. #2
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,387

    Default Re: Phottix strato II setting

    Quote Originally Posted by Limiter View Post
    I just gotten 1 set of the triggers today and tested all functions to work properly except when the receiver mounted on hotshoe with 430ex II on top of it to serve as wireless/wired shutter, the trigger work as per normal but the fire doesn't fire.
    The hotshoe mounting is a convenient way to prevent the trigger from 'hanging around' loosely. It seems to me that the trigger does not support 'flash pass through'. In that case, mount the flash directly on the cam as per normal and attached the trigger to the camera somewhere else. It doesn't need to be mounted on the flash hotshoe.
    EOS

  3. #3

    Default Re: Phottix strato II setting

    Yes bro i did tried with the method you mentioned but the flash just doesn't fire off despite i ensured the setting was right.

    Kinda puzzling me..

  4. #4
    Member
    Join Date
    Jan 2002
    Location
    Singapore
    Posts
    521

    Default

    You did set flash to manual?

  5. #5

    Default Re: Phottix strato II setting

    Yup did all various setup with manual settings only

  6. #6
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,387

    Default Re: Phottix strato II setting

    Quote Originally Posted by Limiter View Post
    Yes bro i did tried with the method you mentioned but the flash just doesn't fire off despite i ensured the setting was right.
    Kinda puzzling me..
    Does it fire if you press the normal shutter button? There is no logical reason why the flash should not fire just because you use an external trigger and not the shutter button.
    EOS

  7. #7

    Default Re: Phottix strato II setting

    It turns out to be a bad copy with hardware issues.

    Went back to shop and did a 1 to 1 exchange and all features are working perfectly.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •