Results 1 to 8 of 8

Thread: Zenitar Fisheye 16mm with M42 EOS Adapter

  1. #1

    Default Zenitar Fisheye 16mm with M42 EOS Adapter

    faced a problem using this lens on my EOS Elan 7E (aka EOS 30). apparently the SLR's mirror will hit the inside of the lens when the shutter is released.

    no such problem when i tried it on my 350D. anyone knows the cause of this? pls help. thanx a million!

  2. #2

    Default

    check out http://photonotes.org/reviews/zenitar-fisheye/

    seems like of all eos bodies, only EOS 30 got this problem. in this case, try screwing out the default rear UV filter, which will give extra 1 to 2 mm for mirror to clear.

    cheers

  3. #3

    Default

    Quote Originally Posted by ipsum34
    check out http://photonotes.org/reviews/zenitar-fisheye/

    seems like of all eos bodies, only EOS 30 got this problem. in this case, try screwing out the default rear UV filter, which will give extra 1 to 2 mm for mirror to clear.

    cheers
    wow am i lucky or wat?! only EOS 30??? thanx a lot dude!

  4. #4

    Default

    Supposedly, this is a more of a problem for the Zenitar with M42 mount + M42 to EOS adaptor. Heard that the Zenitar with dedicated EOS mount is better. Is it possible to swap the mount?

  5. #5

    Default

    I have one on the 20D, no "engineering" issues but my infinity focal point - where everthing is sharp - is at the 60mm mark and not at the usual infinity mark. Is this normal ?

  6. #6

    Default

    i have tried it already. Removing the rear filter solves the problem. My EOS 30 mirror no longer hits the lens.

  7. #7
    Senior Member denniskee's Avatar
    Join Date
    Oct 2003
    Location
    bukit batok
    Posts
    5,468

    Default

    Wormz777 uses zenitar 16mm f2.8 fish-eye on his eos 33 with no problem. Can check with him.

    eos 30 & eos 33 are the same body.
    photography makes one sees things from all angles.

  8. #8

    Default

    Quote Originally Posted by denniskee
    Wormz777 uses zenitar 16mm f2.8 fish-eye on his eos 33 with no problem. Can check with him.

    eos 30 & eos 33 are the same body.
    thanx dude. apparently as long as i dun use a rear filter its fine.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •