Results 1 to 3 of 3

Thread: Nikon D70 Shutter Release Gone Awry

  1. #1

    Question Nikon D70 Shutter Release Gone Awry


    I'm hoping someone has an idea on how to fix my D70. Since purchasing the camera July 2004, I have not had any problems until this past week.

    I am registering an "Err" on the control panel, on the shutter speed area. I will try to take a picture, auto focus will work, it will beep when I press the shutter release halfway. All normal, until I continue to press the shutter release. Looking through the view finder, everything will turn black.

    On the viewfinder display, an Err will flash in the shutter speed section. I have to press the shutter release again for the shutter to release. Unfortunately, no photo will register. Oddly, occasionally if I press twice a photo will appear.

    Have removed and reattached the lens as well as the CF card. This has no effect. I have also tried different modes and sometime a photo will take, but rarely. I have tried attaching a different lens and a different CF card. Also, no impact on the Err. The problem seems to be with the body of the camera.

    Any thoughts?

  2. #2


    Have you tried to press the reset button? Anyway, I suggest you bring it back to Nikon. Let them check it out.

  3. #3
    Senior Member
    Join Date
    Jun 2004


    hmm... reading abt this. it happened to me once... i believe i did not set my aperture ring to the max.... have u tried that? you using kit lens or a D lens?
    Budget wedding photographer :)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts