Results 1 to 14 of 14

Thread: problem with my Nikon 50 1.8

  1. #1

    Default problem with my Nikon 50 1.8

    Need some advise on my nikon 50 1.8
    I hasn't been using tis for quite sometime till today. I mount the Len on my body but there is a error msg keep appearing in the view finder, can't shoot with it at all. I try removing it and remount again but it the same. I try to mount another Len on my camera body and it fine than I try the 50 1.8 again and the same thing happen. Anybody encounter this before?
    Pls advise as the warranty from Nikon Singapore has just over.

  2. #2
    Member Hanmin147's Avatar
    Join Date
    Aug 2011
    Location
    Tampines
    Posts
    127

    Default

    G or D lens? If D then make sure the aperture ring is set to 22 and locked in.

  3. #3
    Moderator catchlights's Avatar
    Join Date
    Sep 2004
    Location
    Punggol, Singapore
    Posts
    21,902

    Default Re: problem with my Nikon 50 1.8

    is it a D lens version?
    do you lock the aperture at f22?
    Shoot to Live, Live to Shoot
    www.benjaminloo.com | iStock portfolio

  4. #4

    Default

    Quote Originally Posted by Hanmin147
    G or D lens? If D then make sure the aperture ring is set to 22 and locked in.
    Should be D len. Anyway I did set it to 22 and lock it but it the same. Wat if it G len?

  5. #5
    Member Hanmin147's Avatar
    Join Date
    Aug 2011
    Location
    Tampines
    Posts
    127

    Default

    Quote Originally Posted by Gikens

    Should be D len. Anyway I did set it to 22 and lock it but it the same. Wat if it G len?
    A G lens won't have a manual aperture dial

  6. #6

    Default

    Quote Originally Posted by Hanmin147

    A G lens won't have a manual aperture dial
    Oic.. still trying to figure out Wat wrong..

  7. #7
    Member Hanmin147's Avatar
    Join Date
    Aug 2011
    Location
    Tampines
    Posts
    127

    Default

    Quote Originally Posted by Gikens

    Oic.. still trying to figure out Wat wrong..
    Next guess would be corroded contacts on the lens?

  8. #8

    Default

    Quote Originally Posted by Hanmin147

    Next guess would be corroded contacts on the lens?
    Wat do u mean by corroded contacts on the len?

  9. #9

    Default

    Quote Originally Posted by Gikens

    Wat do u mean by corroded contacts on the len?
    There is no "Len". It's "lens". He means look at the metal contact points at the mount for dirt and corrosion.
    Alpha

  10. #10
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,392

    Default Re: problem with my Nikon 50 1.8

    I would suggest that TS states exactly what error message comes up. We keep guessing based on his assumptions - which could be wrong in the first place.
    Alternatively TS could check with Nikon Service Center or a fellow Nikon users whether the same error message comes up there as well. That could narrow down the source of the problem. The former one might be able to give immediate advice and (if necessary) costs of repair. Better than wild guessing ...
    Last edited by Octarine; 29th November 2012 at 10:42 AM.
    EOS

  11. #11

    Default

    Quote Originally Posted by Octarine View Post
    I would suggest that TS states exactly what error message comes up. We keep guessing based on his assumptions - which could be wrong in the first place.
    Alternatively TS could check with Nikon Service Center or a fellow Nikon users whether the same error message comes up there as well. That could narrow down the source of the problem. The former one might be able to give immediate advice and (if necessary) costs of repair. Better than wild guessing ...
    Tks for replying. The msg I saw through the view finder is "FEE" if I have not mistaken.

  12. #12
    Member
    Join Date
    Dec 2011
    Location
    Tampines, Singapore
    Posts
    78

    Default Re: problem with my Nikon 50 1.8

    Hello Gikens,

    Maybe this will help? The below mentioned link from Nikon USA Support should be quite informative.

    What does the FEE or F-- error message displayed on an SLR camera mean?

    I encountered something similar some time back with a D300 and one of my lens. I just lightly cleaned the contacts and re-mounted the lens and the error code went away.

    Quote Originally Posted by Gikens View Post
    Tks for replying. The msg I saw through the view finder is "FEE" if I have not mistaken.

  13. #13

    Default

    Quote Originally Posted by nkartikeyan View Post
    Hello Gikens,

    Maybe this will help? The below mentioned link from Nikon USA Support should be quite informative.

    What does the FEE or F-- error message displayed on an SLR camera mean?

    I encountered something similar some time back with a D300 and one of my lens. I just lightly cleaned the contacts and re-mounted the lens and the error code went away.
    Tks for the reply. I will try it tonite or tmr. Will keep u updated of the out come.

  14. #14

    Default

    Quote Originally Posted by nkartikeyan View Post
    Hello Gikens,

    Maybe this will help? The below mentioned link from Nikon USA Support should be quite informative.

    What does the FEE or F-- error message displayed on an SLR camera mean?

    I encountered something similar some time back with a D300 and one of my lens. I just lightly cleaned the contacts and re-mounted the lens and the error code went away.
    TS, tks for the advise, I did try cleaning the contact but still the same. I think it need servicing already.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •