Results 1 to 15 of 15

Thread: Maha charger help!!

  1. #1
    Senior Member +evenstar's Avatar
    Join Date
    Jan 2004
    Location
    Singapore / United Kingdom
    Posts
    5,655

    Default Maha charger help!!

    My Maha charger seems to have a problem. As this charger charges each battery individually, there are 4 LED indicators. However, I found out that there's one indicator that keeps on showing the red light, which means that the battery is still charging. This problem occurs even though I leave the batteries charging overnight, hence I'm not sure whether this is a problem with the LED indicator or the charger...

    Anyone knows what may be the problem? Or should I just go back to EastGear to change one? (FYI, I've already had a change of chargers 3 weeks ago as my previous maha charger also had a problem, and this is the new copy )
    eat. drink. shoot

  2. #2
    Member
    Join Date
    Nov 2003
    Location
    Away From Keyboard
    Posts
    1,176

    Wink

    Quote Originally Posted by +evenstar
    My Maha charger seems to have a problem. As this charger charges each battery individually, there are 4 LED indicators. However, I found out that there's one indicator that keeps on showing the red light, which means that the battery is still charging. This problem occurs even though I leave the batteries charging overnight, hence I'm not sure whether this is a problem with the LED indicator or the charger...

    Anyone knows what may be the problem? Or should I just go back to EastGear to change one? (FYI, I've already had a change of chargers 3 weeks ago as my previous maha charger also had a problem, and this is the new copy )
    Try charging the same battery in another slot. Sometime, its the battery.

  3. #3

    Default

    Quote Originally Posted by +evenstar
    My Maha charger seems to have a problem. As this charger charges each battery individually, there are 4 LED indicators. However, I found out that there's one indicator that keeps on showing the red light, which means that the battery is still charging. This problem occurs even though I leave the batteries charging overnight, hence I'm not sure whether this is a problem with the LED indicator or the charger...

    Anyone knows what may be the problem? Or should I just go back to EastGear to change one? (FYI, I've already had a change of chargers 3 weeks ago as my previous maha charger also had a problem, and this is the new copy )
    Did u select the FAST charge mode or SLOW mode (switch is on the side of the charger)? Shouldn't take more than 2hrs or so to fully charge ur batt (based on Mi-NH 2500)...

    My set didn't have this prob... if this persists, probably better to send it back to Eastgear to replace it... Good luck..
    Jia Wang... "A photo is only as beautiful as the photographer's eyes can see."
    My Eyes ;)

  4. #4

    Default

    Same thing happened to mine ... I just unplug, make sure it's on "slow" charge, swap the batteries around, and re-insert into the plug. Been ok for me so far, and I like having the individual charging channels.

  5. #5
    Member
    Join Date
    Jan 2005
    Location
    Singapore
    Posts
    9

    Default

    East Gear has run out of Maha chargers - coming in at the end of the month. Anybody know where else to get one?

  6. #6
    Deregistered
    Join Date
    Dec 2002
    Location
    Planet Nikon
    Posts
    21,905

    Default

    Just got mine today @ TK Foto

  7. #7

  8. #8
    Member
    Join Date
    Nov 2004
    Location
    Planet Earth
    Posts
    443

    Default

    so is Maha, Sanyo or Eastgear chargers the best for AA-sized 2500mah NiMH batteries? need to get one soon from Eastgear to replace my cranky Sony charger and make the decision quick.

  9. #9
    Senior Member
    Join Date
    Sep 2003
    Location
    In this small world
    Posts
    3,142

    Default

    Dun you guys think that the 2500 batteries from Sanyo are a bit bigger than normal? I seems not to be able to fit it nicely onto my lightbox

  10. #10
    Member
    Join Date
    Nov 2004
    Location
    Planet Earth
    Posts
    443

    Default

    Quote Originally Posted by espn
    Just got mine today @ TK Foto
    where's TK photo?

  11. #11
    Member
    Join Date
    May 2003
    Location
    Singapore
    Posts
    669

    Default

    http://www.tkfoto.com.sg/online/


    Quote Originally Posted by nad
    where's TK photo?

  12. #12
    Member
    Join Date
    Nov 2004
    Location
    Planet Earth
    Posts
    443

    Default

    Quote Originally Posted by plinius

    thanks!!

  13. #13

    Default

    Quote Originally Posted by Jia Wang
    Did u select the FAST charge mode or SLOW mode (switch is on the side of the charger)? Shouldn't take more than 2hrs or so to fully charge ur batt (based on Mi-NH 2500)...

    My set didn't have this prob... if this persists, probably better to send it back to Eastgear to replace it... Good luck..
    if on slow mode, can it still charge sanyo 2500 AA batteries within 2 hrs? i realised all my sanyo 2100 sets r takin more den 4 hrs

  14. #14

    Default

    if on slow mode, it cannot charge a fully discharged Sanyo 2500 AA battery within 2 hours. Mine takes around 8 hours on slow mode (usually charge it overnight).

  15. #15

    Default

    oh oki yeap yeap it's abt tat time. i tot my charger/batts spoilt.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •