Results 1 to 5 of 5

Thread: Flash unit firing at full power even with the lowest settings in manual mode.

  1. #1

    Default Flash unit firing at full power even with the lowest settings in manual mode.

    I am currently owning a nissin di866 mark 1 flash with an eos 60d camera. It seems that the flash would always fire at full power no matter what settings i set it on in manual mode. Furthermore, the pictures that i have taken in a pitch black room with the flash at full and lowest power is the same. Both are extremely overexpose. Fruthermore, the ttl mode and auto mode on this flash always underexposes the image very badly and i am using direct flash when taking the pictures. Is this a faulty unit? Should i return it to shashinki and ask for another di866 unit to replace this faulty one? I can still return it for free until this friday.

  2. #2

    Default

    If u do manual mode (as if flash in manual mode), u do have to step it down. As most of the time it will stay at 1/1 power ratio by default i guess.
    For your auto camera mode, u can play around with flash compensation. Or maybe u choose wrong metering system somehow...

  3. #3

    Default Re: Flash unit firing at full power even with the lowest settings in manual mode.

    I already adjusted the flash to fire at the weakest setting and it still fires at full power. What is the problems? Or should i spend double the money and get the 580 ex2 instead and trade this in for a refund?

  4. #4

    Default

    That one i cant help. Just ask the store about how to operate the flash. If its problematic, of course the shop has to take responsibility

  5. #5
    Moderator catchlights's Avatar
    Join Date
    Sep 2004
    Location
    Punggol, Singapore
    Posts
    21,901

    Default Re: Flash unit firing at full power even with the lowest settings in manual mode.

    Quote Originally Posted by aarontan95 View Post
    I am currently owning a nissin di866 mark 1 flash with an eos 60d camera. It seems that the flash would always fire at full power no matter what settings i set it on in manual mode. Furthermore, the pictures that i have taken in a pitch black room with the flash at full and lowest power is the same. Both are extremely overexpose. Fruthermore, the ttl mode and auto mode on this flash always underexposes the image very badly and i am using direct flash when taking the pictures. Is this a faulty unit? Should i return it to shashinki and ask for another di866 unit to replace this faulty one? I can still return it for free until this friday.
    Why don't you just contact shashink to tell them is problem?
    Shoot to Live, Live to Shoot
    www.benjaminloo.com | iStock portfolio

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •